aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc9
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc9')
-rw-r--r--lang/gcc9/Makefile4
-rw-r--r--lang/gcc9/distinfo6
-rw-r--r--lang/gcc9/files/patch-amd64-gcc-multilib-support73
-rw-r--r--lang/gcc9/files/patch-powerpc64-no-_GNU_SOURCE27
4 files changed, 4 insertions, 106 deletions
diff --git a/lang/gcc9/Makefile b/lang/gcc9/Makefile
index 5391c548f67a..868651384298 100644
--- a/lang/gcc9/Makefile
+++ b/lang/gcc9/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 9.1.0
-PORTREVISION= 1
+PORTVERSION= 9.2.0
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
@@ -61,7 +60,6 @@ CONFIGURE_ARGS+= --disable-multilib
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.elif ${ARCH} == powerpc64
-PORTREVISION= 2
CONFIGURE_ENV+= UNAME_m="powerpc64"
USE_GCC= 8
.endif
diff --git a/lang/gcc9/distinfo b/lang/gcc9/distinfo
index bd98015884f7..33faef9c615d 100644
--- a/lang/gcc9/distinfo
+++ b/lang/gcc9/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557690023
-SHA256 (gcc-9.1.0.tar.xz) = 79a66834e96a6050d8fe78db2c3b32fb285b230b855d0a66288235bc04b327a0
-SIZE (gcc-9.1.0.tar.xz) = 70546856
+TIMESTAMP = 1565818139
+SHA256 (gcc-9.2.0.tar.xz) = ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206
+SIZE (gcc-9.2.0.tar.xz) = 70607648
diff --git a/lang/gcc9/files/patch-amd64-gcc-multilib-support b/lang/gcc9/files/patch-amd64-gcc-multilib-support
deleted file mode 100644
index ffae93210614..000000000000
--- a/lang/gcc9/files/patch-amd64-gcc-multilib-support
+++ /dev/null
@@ -1,73 +0,0 @@
---- UTC
-Index: gcc/config.gcc
-===================================================================
---- gcc/config.gcc (revision 269726)
-+++ gcc/config.gcc (working copy)
-@@ -4925,8 +4925,11 @@
- ;;
- i[34567]86-*-dragonfly* | x86_64-*-dragonfly*)
- ;;
-- i[34567]86-*-freebsd* | x86_64-*-freebsd*)
-+ i[34567]86-*-freebsd*)
- ;;
-+ x86_64-*-freebsd*)
-+ tmake_file="${tmake_file} i386/t-freebsd64"
-+ ;;
- ia64*-*-linux*)
- ;;
-
-Index: gcc/config/i386/freebsd64.h
-===================================================================
---- gcc/config/i386/freebsd64.h (revision 269733)
-+++ gcc/config/i386/freebsd64.h (working copy)
-@@ -31,7 +31,7 @@
-
- #undef LINK_SPEC
- #define LINK_SPEC "\
-- %{m32:-m elf_i386_fbsd} \
-+ %{m32:-m elf_i386_fbsd}%{!m32:-m elf_x86_64_fbsd} \
- %{p:%nconsider using '-pg' instead of '-p' with gprof(1)} \
- %{v:-V} \
- %{assert*} %{R*} %{rpath*} %{defsym*} \
-@@ -42,3 +42,6 @@
- -dynamic-linker %(fbsd_dynamic_linker) } \
- %{static:-Bstatic}} \
- %{symbolic:-Bsymbolic}"
-+
-+#undef MULTILIB_DEFAULTS
-+#define MULTILIB_DEFAULTS { "m64" }
-Index: gcc/config/i386/t-freebsd64
-===================================================================
---- gcc/config/i386/t-freebsd64 (nonexistent)
-+++ gcc/config/i386/t-freebsd64 (working copy)
-@@ -0,0 +1,30 @@
-+# Copyright (C) 2019 Free Software Foundation, Inc.
-+#
-+# This file is part of GCC.
-+#
-+# GCC is free software; you can redistribute it and/or modify
-+# it under the terms of the GNU General Public License as published by
-+# the Free Software Foundation; either version 3, or (at your option)
-+# any later version.
-+#
-+# GCC is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+# GNU General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License
-+# along with GCC; see the file COPYING3. If not see
-+# <http://www.gnu.org/licenses/>.
-+
-+# The 32-bit libraries are found in /usr/lib32
-+
-+# To support i386 and x86-64, the directory structrue
-+# should be:
-+#
-+# /lib has x86-64 libraries.
-+# /lib32 has i386 libraries.
-+#
-+
-+MULTILIB_OPTIONS = m32
-+MULTILIB_DIRNAMES = 32
-+MULTILIB_OSDIRNAMES = ../lib32
diff --git a/lang/gcc9/files/patch-powerpc64-no-_GNU_SOURCE b/lang/gcc9/files/patch-powerpc64-no-_GNU_SOURCE
deleted file mode 100644
index 4303b436fb9d..000000000000
--- a/lang/gcc9/files/patch-powerpc64-no-_GNU_SOURCE
+++ /dev/null
@@ -1,27 +0,0 @@
-r274105 | amodra | 2019-08-05 01:52:33 +0000
-
-PR91349, powerpc64*-*-freebsd* defines _GNU_SOURCE
-
-rev 266496 (git ab6b1bb456) undefined some macros in rs6000/freebsd.h
-but missed doing the same in rs6000/freebsd64.h.
-
- PR target/91349
- * config/rs6000/freebsd64.h (CPLUSPLUS_CPP_SPEC),
- (LINK_GCC_C_SEQUENCE_SPEC): Undef.
-
---- UTC
-Index: gcc/config/rs6000/freebsd64.h
-===================================================================
---- gcc/config/rs6000/freebsd64.h (revision 274104)
-+++ gcc/config/rs6000/freebsd64.h (revision 274105)
-@@ -17,6 +17,10 @@
- along with GCC; see the file COPYING3. If not see
- <http://www.gnu.org/licenses/>. */
-
-+/* Undef gnu-user.h macros we don't want. */
-+#undef CPLUSPLUS_CPP_SPEC
-+#undef LINK_GCC_C_SEQUENCE_SPEC
-+
- /* Override the defaults, which exist to force the proper definition. */
-
- #ifdef IN_LIBGCC2