aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/bsd.cabal.options.mk
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ghc/bsd.cabal.options.mk')
-rw-r--r--lang/ghc/bsd.cabal.options.mk14
1 files changed, 11 insertions, 3 deletions
diff --git a/lang/ghc/bsd.cabal.options.mk b/lang/ghc/bsd.cabal.options.mk
index ca06b7974bc0..ae70ad7ec24e 100644
--- a/lang/ghc/bsd.cabal.options.mk
+++ b/lang/ghc/bsd.cabal.options.mk
@@ -18,19 +18,27 @@ GHC_CMD?= ${LOCALBASE}/bin/ghc
HADDOCK_CMD?= ${LOCALBASE}/bin/haddock
HSCOLOUR_CMD?= ${LOCALBASE}/bin/HsColour
-GHC_VERSION?= 7.8.3
+GHC_VERSION?= 7.10.2
+LLVM_VERSION= 35
HSCOLOUR_DESC?= Colorize generated documentation by HsColour
DYNAMIC_DESC?= Add support for dynamic linking
PROFILE_DESC?= Add support for profiling
LLVM_DESC?= Use the LLVM backend for code generation
+GCC_DESC= Build with GCC (from ports)
+PCLANG_DESC= Build with Clang from ports
+BCLANG_DESC= Build with Clang from base
-.if (!exists(${GHC_CMD}) || exists(${LOCALBASE}/lib/ghc-${GHC_VERSION}/ghc-${GHC_VERSION}/GHC.dyn_hi)) && !defined(IGNORE_DYNAMIC)
+OPTIONS_SINGLE+= C_Compiler
+OPTIONS_SINGLE_C_Compiler= GCC PCLANG BCLANG
+OPTIONS_DEFAULT+= GCC
+
+.if (!exists(${GHC_CMD}) || exists(${LOCALBASE}/lib/ghc-${GHC_VERSION}/rts/libHSrts-ghc${GHC_VERSION}.so)) && !defined(IGNORE_DYNAMIC)
OPTIONS_DEFINE+= DYNAMIC
OPTIONS_DEFAULT+= DYNAMIC
.endif
-.if (!exists(${GHC_CMD}) || exists(${LOCALBASE}/lib/ghc-${GHC_VERSION}/ghc-${GHC_VERSION}/GHC.p_hi)) && !defined(IGNORE_PROFILE)
+.if (!exists(${GHC_CMD}) || exists(${LOCALBASE}/lib/ghc-${GHC_VERSION}/rts/libHSrts_p.a)) && !defined(IGNORE_PROFILE)
OPTIONS_DEFINE+= PROFILE
.endif