aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ghc/files')
-rw-r--r--lang/ghc/files/patch-compiler_main_SysTools.hs12
-rw-r--r--lang/ghc/files/patch-configure.ac22
-rw-r--r--lang/ghc/files/patch-ghc.mk10
-rw-r--r--lang/ghc/files/patch-includes_rts_storage_ClosureMacros.h22
-rw-r--r--lang/ghc/files/patch-libraries_Cabal_Cabal_Distribution_Simple_GHC.hs11
-rw-r--r--lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs12
-rw-r--r--lang/ghc/files/patch-rts_Linker.c11
7 files changed, 22 insertions, 78 deletions
diff --git a/lang/ghc/files/patch-compiler_main_SysTools.hs b/lang/ghc/files/patch-compiler_main_SysTools.hs
deleted file mode 100644
index 06dce352555a..000000000000
--- a/lang/ghc/files/patch-compiler_main_SysTools.hs
+++ /dev/null
@@ -1,12 +0,0 @@
---- compiler/main/SysTools.hs.orig 2017-08-12 09:25:57 UTC
-+++ compiler/main/SysTools.hs
-@@ -907,6 +907,9 @@ getCompilerInfo' dflags = do
- -- Regular clang
- | any ("clang version" `isInfixOf`) stde =
- return Clang
-+ -- FreeBSD clang
-+ | any ("FreeBSD clang version" `isInfixOf`) stde =
-+ return Clang
- -- XCode 5.1 clang
- | any ("Apple LLVM version 5.1" `isPrefixOf`) stde =
- return AppleClang51
diff --git a/lang/ghc/files/patch-configure.ac b/lang/ghc/files/patch-configure.ac
index 8906fbb875dd..5a4a978d08ba 100644
--- a/lang/ghc/files/patch-configure.ac
+++ b/lang/ghc/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2017-01-04 14:17:17 UTC
+--- configure.ac.orig 2018-03-06 16:48:53 UTC
+++ configure.ac
-@@ -418,6 +418,9 @@ AC_SUBST([SplitObjsBroken])
+@@ -447,6 +447,9 @@ XCODE_VERSION()
dnl ** Building a cross compiler?
dnl --------------------------------------------------------------
CrossCompiling=NO
@@ -10,15 +10,15 @@
# If 'host' and 'target' differ, then this means we are building a cross-compiler.
if test "$TargetPlatform" != "$HostPlatform" ; then
CrossCompiling=YES
-@@ -1057,6 +1060,11 @@ if test "$ac_cv_sizeof_void_p" -eq 8 ; then
- use_large_address_space=yes
- elif test "$ghc_host_os" = "openbsd" ; then
- # as of OpenBSD 5.8 (2015), OpenBSD does not support mmap with MAP_NORESERVE.
-+ # The flag MAP_NORESERVE is supported for source compatibility reasons,
-+ # but is completely ignored by OS mmap
-+ use_large_address_space=no
-+ elif test "$ghc_host_os" = "freebsd" ; then
-+ # FreeBSD does not support mmap with MAP_NORESERVE,r emoved in r273250.
+@@ -1163,6 +1158,11 @@ if test "$ac_cv_sizeof_void_p" -eq 8 ; t
# The flag MAP_NORESERVE is supported for source compatibility reasons,
# but is completely ignored by OS mmap
use_large_address_space=no
++ elif test "$ghc_host_os" = "freebsd" ; then
++ # FreeBSD does not support mmap with MAP_NORESERVE, removed in r273250.
++ # The flag MAP_NORESERVE is supported for source compatibility reasons,
++ # but is completely ignored by OS mmap
++ use_large_address_space=no
+ else
+ AC_CHECK_DECLS([MAP_NORESERVE, MADV_FREE, MADV_DONTNEED],[],[],
+ [
diff --git a/lang/ghc/files/patch-ghc.mk b/lang/ghc/files/patch-ghc.mk
index 8ffda7a16712..8ab4d6e13130 100644
--- a/lang/ghc/files/patch-ghc.mk
+++ b/lang/ghc/files/patch-ghc.mk
@@ -8,14 +8,14 @@
else
$(error Make has restarted itself $(MAKE_RESTARTS) times; is there a makefile bug? See http://ghc.haskell.org/trac/ghc/wiki/Building/Troubleshooting#Makehasrestarteditself3timesisthereamakefilebug for details)
endif
-@@ -465,10 +466,7 @@ PACKAGES_STAGE1 += ghc-boot
+@@ -459,10 +460,7 @@ PACKAGES_STAGE1 += ghc-boot-th
+ PACKAGES_STAGE1 += ghc-boot
PACKAGES_STAGE1 += template-haskell
- PACKAGES_STAGE1 += hoopl
- PACKAGES_STAGE1 += transformers
+ PACKAGES_STAGE1 += ghc-compact
-
-ifeq "$(HADDOCK_DOCS)" "YES"
PACKAGES_STAGE1 += xhtml
-endif
- ifeq "$(Windows_Target)" "NO"
- ifneq "$(TargetOS_CPP)" "ios"
+ ifeq "$(WITH_TERMINFO)" "YES"
+ PACKAGES_STAGE1 += terminfo
diff --git a/lang/ghc/files/patch-includes_rts_storage_ClosureMacros.h b/lang/ghc/files/patch-includes_rts_storage_ClosureMacros.h
deleted file mode 100644
index 77e317c60036..000000000000
--- a/lang/ghc/files/patch-includes_rts_storage_ClosureMacros.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- includes/rts/storage/ClosureMacros.h.orig 2018-01-03 13:27:55 UTC
-+++ includes/rts/storage/ClosureMacros.h
-@@ -499,8 +499,17 @@ INLINE_HEADER StgWord8 *mutArrPtrsCard (
-
- -------------------------------------------------------------------------- */
-
--#define ZERO_SLOP_FOR_LDV_PROF (defined(PROFILING))
--#define ZERO_SLOP_FOR_SANITY_CHECK (defined(DEBUG) && !defined(THREADED_RTS))
-+#if defined(PROFILING)
-+#define ZERO_SLOP_FOR_LDV_PROF 1
-+#else
-+#define ZERO_SLOP_FOR_LDV_PROF 0
-+#endif
-+
-+#if defined(DEBUG) && !defined(THREADED_RTS)
-+#define ZERO_SLOP_FOR_SANITY_CHECK 1
-+#else
-+#define ZERO_SLOP_FOR_SANITY_CHECK 0
-+#endif
-
- #if ZERO_SLOP_FOR_LDV_PROF || ZERO_SLOP_FOR_SANITY_CHECK
- #define OVERWRITING_CLOSURE(c) overwritingClosure(c)
diff --git a/lang/ghc/files/patch-libraries_Cabal_Cabal_Distribution_Simple_GHC.hs b/lang/ghc/files/patch-libraries_Cabal_Cabal_Distribution_Simple_GHC.hs
deleted file mode 100644
index c7ddc4addf4f..000000000000
--- a/lang/ghc/files/patch-libraries_Cabal_Cabal_Distribution_Simple_GHC.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- libraries/Cabal/Cabal/Distribution/Simple/GHC.hs.orig 2017-01-03 15:59:20 UTC
-+++ libraries/Cabal/Cabal/Distribution/Simple/GHC.hs
-@@ -996,7 +996,7 @@ getRPaths lbi clbi | supportRPaths hostOS = do
- supportRPaths Linux   = True
- supportRPaths Windows = False
- supportRPaths OSX   = True
-- supportRPaths FreeBSD   = False
-+ supportRPaths FreeBSD   = True
- supportRPaths OpenBSD   = False
- supportRPaths NetBSD   = False
- supportRPaths DragonFly = False
diff --git a/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs b/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs
index 18f937335935..96b536dc0eab 100644
--- a/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs
+++ b/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs
@@ -1,15 +1,15 @@
---- libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs.orig 2017-01-03 15:59:20 UTC
+--- libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs.orig 2017-11-28 16:40:34 UTC
+++ libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs
-@@ -54,6 +54,8 @@ import Distribution.Compat.Exception
+@@ -59,6 +59,8 @@ import Distribution.Compat.Exception
import Distribution.Verbosity
import Distribution.Version
+import System.FilePath (takeDirectory)
+
- import Data.Char
- ( isDigit )
import qualified Data.Map as Map
-@@ -251,11 +253,13 @@ alexProgram = (simpleProgram "alex") {
+
+ -- ------------------------------------------------------------
+@@ -265,11 +267,13 @@ alexProgram = (simpleProgram "alex") {
gccProgram :: Program
gccProgram = (simpleProgram "gcc") {
@@ -26,7 +26,7 @@
stripProgram :: Program
stripProgram = (simpleProgram "strip") {
-@@ -311,7 +315,9 @@ greencardProgram :: Program
+@@ -337,7 +341,9 @@ greencardProgram :: Program
greencardProgram = simpleProgram "greencard"
ldProgram :: Program
diff --git a/lang/ghc/files/patch-rts_Linker.c b/lang/ghc/files/patch-rts_Linker.c
deleted file mode 100644
index 9597fe887603..000000000000
--- a/lang/ghc/files/patch-rts_Linker.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- rts/Linker.c.orig 2017-08-12 09:22:13 UTC
-+++ rts/Linker.c
-@@ -797,7 +797,7 @@ initLinker_ (int retain_cafs)
- # endif /* RTLD_DEFAULT */
-
- compileResult = regcomp(&re_invalid,
-- "(([^ \t()])+\\.so([^ \t:()])*):([ \t])*(invalid ELF header|file too short)",
-+ "(([^ \t()])+\\.so([^ \t:()])*):([ \t])*(invalid ELF header|file too short|invalid file format)",
- REG_EXTENDED);
- if (compileResult != 0) {
- barf("Compiling re_invalid failed");