aboutsummaryrefslogtreecommitdiff
path: root/lang/guile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/guile/Makefile')
-rw-r--r--lang/guile/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index bc326690396d..94d8a8af53ba 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= guile
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= guile
@@ -18,12 +19,14 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFILES= configure guile-readline/configure
CONFIGURE_ARGS= --with-threads
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
PLIST_SUB= GUILE_VER=${PORTVERSION}
post-patch:
@(cd ${WRKSRC} ; \
- ${FIND} * -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
+ ${FIND} . -type f -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
"s|<malloc.h>|<stdlib.h>|g")
.include <bsd.port.mk>