aboutsummaryrefslogtreecommitdiff
path: root/lang/hope
diff options
context:
space:
mode:
Diffstat (limited to 'lang/hope')
-rw-r--r--lang/hope/Makefile28
-rw-r--r--lang/hope/files/patch-doc--Makefile.in29
-rw-r--r--lang/hope/files/patch-doc:Makefile.in19
-rw-r--r--lang/hope/files/patch-lib--Makefile.in18
-rw-r--r--lang/hope/files/patch-src--Makefile.in15
-rw-r--r--lang/hope/files/patch-src--memory.c (renamed from lang/hope/files/patch-src-memory.c)0
-rw-r--r--lang/hope/pkg-plist1
7 files changed, 70 insertions, 40 deletions
diff --git a/lang/hope/Makefile b/lang/hope/Makefile
index f235fd6fa492..1d87fe8fbe89 100644
--- a/lang/hope/Makefile
+++ b/lang/hope/Makefile
@@ -10,31 +10,17 @@ DISTNAME= ${PORTNAME}
MAINTAINER= lev@FreeBSD.org
COMMENT= Hope is lazy interpreter for HOPE applicative language
-.if defined(WITH_DOCS)
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
USE_TEX= latex:build
BUILD_DEPENDS+= latex2html:${PORTSDIR}/textproc/latex2html
MAKE_ARGS+= WITH_DOCS=yes
-.else
-NOPORTDOCS= yes
.endif
+USES= gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-
-MAN1= hope.1
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-pre-fetch:
-.if !defined(WITH_DOCS)
- @${ECHO} ""
- @${ECHO} " If you want to build and install documentation"
- @${ECHO} " you should use WITH_DOCS build option"
- @${ECHO} ""
- @${ECHO} " Documentation is not builded by default because"
- @${ECHO} " it needs latex and latex2html"
- @${ECHO} ""
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/hope/files/patch-doc--Makefile.in b/lang/hope/files/patch-doc--Makefile.in
new file mode 100644
index 000000000000..8ffb31ff0d70
--- /dev/null
+++ b/lang/hope/files/patch-doc--Makefile.in
@@ -0,0 +1,29 @@
+--- doc/Makefile.in.orig 2003-12-08 21:44:47.000000000 +0300
++++ doc/Makefile.in 2014-05-18 23:59:23.000000000 +0400
+@@ -58,7 +58,7 @@
+ sed -n 's/^#define[ ][ ]*\(M[IA][NX]PREC\)[ ][ ]*\([0-9]*\).*/\\newcommand{\\\1}{\2}/p' ../src/op.h >$@
+
+ ../src/op.h:
+- cd ../src; make op.h
++ cd ../src; $(MAKE) op.h
+
+ # can't use echo here as BSD and SYSV versions treat backslashes differently.
+ Standard.tex: ../lib/Standard.hop h2l.awk
+@@ -79,11 +79,12 @@
+ $(LATEX2HTML) -address '$(Ross)' examples.tex
+
+ install: all
+- $(INSTALL) -d $(docdir)
+- for file in $(docs); do gzip <$$file >$(docdir)/$$file.gz; done
+- $(INSTALL) -d $(htmldir)
+- for dir in $(dirs); do rm -rf $(htmldir)/$$dir; done
+- cp -r $(dirs) $(htmldir)
++ $(INSTALL) -d $(DESTDIR)$(docdir)
++ for file in $(docs); do gzip <$$file >$(DESTDIR)$(docdir)/$$file.gz; done
++ $(INSTALL) -d $(DESTDIR)$(htmldir)
++ for dir in $(dirs); do rm -rf $(DESTDIR)$(htmldir)/$$dir; done
++ for dir in $(dirs); do rm -rf $(DESTDIR)$$dir/*.pl $(DESTDIR)$$dir/WARNINGS; done
++ cp -r $(dirs) $(DESTDIR)$(htmldir)
+ # cp $(src_srcs) $(srcdir)
+
+ clean:
diff --git a/lang/hope/files/patch-doc:Makefile.in b/lang/hope/files/patch-doc:Makefile.in
deleted file mode 100644
index 0cc6ac6e804a..000000000000
--- a/lang/hope/files/patch-doc:Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- doc/Makefile.in.orig Sat Apr 17 04:14:06 1999
-+++ doc/Makefile.in Tue Sep 25 00:12:51 2001
-@@ -58,7 +58,7 @@
- sed -n 's/^#define[ ][ ]*\(M[IA][NX]PREC\)[ ][ ]*\([0-9]*\).*/\\newcommand{\\\1}{\2}/p' ../src/op.h >$@
-
- ../src/op.h:
-- cd ../src; make op.h
-+ cd ../src; $(MAKE) op.h
-
- # can't use echo here as BSD and SYSV versions treat backslashes differently.
- Standard.tex: ../lib/Standard.hop h2l.awk
-@@ -83,6 +83,7 @@
- for file in $(docs); do gzip <$$file >$(docdir)/$$file.gz; done
- $(INSTALL) -d $(htmldir)
- for dir in $(dirs); do rm -rf $(htmldir)/$$dir; done
-+ for dir in $(dirs); do rm -rf $$dir/*.pl $$dir/WARNINGS; done
- cp -r $(dirs) $(htmldir)
- # cp $(src_srcs) $(srcdir)
-
diff --git a/lang/hope/files/patch-lib--Makefile.in b/lang/hope/files/patch-lib--Makefile.in
new file mode 100644
index 000000000000..d8039c02119d
--- /dev/null
+++ b/lang/hope/files/patch-lib--Makefile.in
@@ -0,0 +1,18 @@
+--- lib/Makefile.in.orig 1999-04-16 18:21:45.000000000 +0400
++++ lib/Makefile.in 2014-05-19 00:03:58.000000000 +0400
+@@ -14,11 +14,11 @@
+ all:
+
+ install:
+- $(INSTALL) -d $(hopelib)
+- for f in *.hop; do $(INSTALL_DATA) $$f $(hopelib); done
+- $(INSTALL) -d $(newlib)
++ $(INSTALL) -d $(DESTDIR)$(hopelib)
++ for f in *.hop; do $(INSTALL_DATA) $$f $(DESTDIR)$(hopelib); done
++ $(INSTALL) -d $(DESTDIR)$(newlib)
+ sed -f list.sed Standard.hop >Standard-new.hop
+- $(INSTALL_DATA) Standard-new.hop $(newlib)/Standard.hop
++ $(INSTALL_DATA) Standard-new.hop $(DESTDIR)$(newlib)/Standard.hop
+ rm -f Standard-new.hop
+
+ distclean clean clobber:
diff --git a/lang/hope/files/patch-src--Makefile.in b/lang/hope/files/patch-src--Makefile.in
new file mode 100644
index 000000000000..bb0cee6c4d64
--- /dev/null
+++ b/lang/hope/files/patch-src--Makefile.in
@@ -0,0 +1,15 @@
+--- src/Makefile.in.orig 2005-10-12 12:39:07.000000000 +0400
++++ src/Makefile.in 2014-05-19 00:04:47.000000000 +0400
+@@ -53,9 +53,9 @@
+ all: $(name) $(name).1
+
+ install: check $(name).1
+- $(INSTALL) -d $(hopelib)
+- $(INSTALL_PROGRAM) -s $(name) $(bindir)
+- $(INSTALL_DATA) $(name).1 $(mandir)
++ $(INSTALL) -d $(DESTDIR)$(hopelib)
++ $(INSTALL_PROGRAM) -s $(name) $(DESTDIR)$(bindir)
++ $(INSTALL_DATA) $(name).1 $(DESTDIR)$(mandir)
+
+ $(name).1: $(name).1.in
+ sed -e 's:@hopelib@:$(hopelib):' -e 's:@fullpath@:$(bindir)/$(name):' $(name).1.in >$@
diff --git a/lang/hope/files/patch-src-memory.c b/lang/hope/files/patch-src--memory.c
index 3d0f50cfac41..3d0f50cfac41 100644
--- a/lang/hope/files/patch-src-memory.c
+++ b/lang/hope/files/patch-src--memory.c
diff --git a/lang/hope/pkg-plist b/lang/hope/pkg-plist
index 822e68295a61..b7c67ba78ab6 100644
--- a/lang/hope/pkg-plist
+++ b/lang/hope/pkg-plist
@@ -1,4 +1,5 @@
bin/hope
+man/man1/hope.1.gz
share/hope/lib.new/Standard.hop
share/hope/lib/Standard.hop
share/hope/lib/arith.hop