aboutsummaryrefslogtreecommitdiff
path: root/lang/icc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/icc/Makefile')
-rw-r--r--lang/icc/Makefile54
1 files changed, 0 insertions, 54 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 9e5c0dc8c93c..93251e43aded 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -57,24 +57,8 @@ EXTRACT_AFTER_ARGS= | tar -xf - \
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
-.if ( ${OSVERSION} < 502108 )
-PLIST_SUB+= MACHINE__TYPES_H="@comment " STDARG_H="" SYS_CDEFS_H="" \
- STDBOOL_H=""
-.else
-PLIST_SUB+= STDARG_H="@comment " SYS_CDEFS_H="@comment "
-.if ( ${OSVERSION} < 503103 || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600013 ) )
-PLIST_SUB+= MACHINE__TYPES_H="" STDBOOL_H=""
-.else
-PLIST_SUB+= MACHINE__TYPES_H="@comment " STDBOOL_H="@comment "
-.endif
-.if ${OSVERSION} < 502126
-GCCCOMPATVER= 330
-.endif
-.if ${OSVERSION} >= 502126
GCCCOMPATVER= 340
-.endif
GXXINCLUDE= /usr/include/c++/${GCCCOMPATVER:C/([0-9])([0-9]).+/\1.\2/}
-.endif
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file})
@@ -143,49 +127,19 @@ post-patch:
# Provide a more FreeBSD'ish compile environment
.for i in icc.cfg icpc.cfg
@${ECHO_CMD} -e "-Qlocation,ld,${PREFIX}/${COMPILERDIR}/bin/ldwrapper\n\n-wr1125\n-we140\n\n-Ulinux\n-U__linux__\n-U__linux\n-U__gnu_linux__\n\n-D__FreeBSD__=${ICCCFGVAL}\n\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
-.if ( ${OSVERSION} >= 500039 )
@${ECHO_CMD} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
-.endif
-.if ( ${OSVERSION} >= 502108 )
@${ECHO_CMD} -e "-restrict\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
-.else
- @${ECHO_CMD} -e "-no-gcc\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
-.endif
@${CHMOD} a-x,g-w ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endfor
# C++ hack for icpc
-.if ( ${OSVERSION} >= 502108 )
@${ECHO_CMD} -e "-gcc-version=${GCCCOMPATVER}\n-cxxlib-gcc\n" \
>>${WRKSRC}/opt/${COMPILERDIR}/bin/icpc.cfg
-.else
- @${ECHO_CMD} -e "\n-I${PREFIX}/include/stlport\n-Qoption,ld,-CPLUSPLUS\n" \
- >>${WRKSRC}/opt/${COMPILERDIR}/bin/icpc.cfg
-.endif
@cd ${WRKSRC}/opt/${COMPILERDIR}/bin/ && ${LN} -s icc.cfg iccbin.cfg \
&& ${LN} -s icpc.cfg icpcbin.cfg
-.if ( ${OSVERSION} < 502108 )
-# Hack while there's no support for ICC in the stdarg.h and sys/cdefs.h.
- @${CP} ${FILESDIR}/stdarg.h ${WRKSRC}/opt/${COMPILERDIR}/include
- @${MKDIR} ${WRKSRC}/opt/${COMPILERDIR}/include/sys
- @${CP} ${FILESDIR}/cdefs.h ${WRKSRC}/opt/${COMPILERDIR}/include/sys
-.endif
-.if ( ( ${OSVERSION} >= 502108 && ${OSVERSION} < 503103 ) || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600013 ) )
-# Work around bug for ICC support in src/sys/i386/include/_types.h.
- @${MKDIR} ${WRKSRC}/opt/${COMPILERDIR}/include/machine
- @${CP} ${FILESDIR}/_types.h ${WRKSRC}/opt/${COMPILERDIR}/include/machine
-.endif
-.if ( ${OSVERSION} < 503103 || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600013 ) )
-# Work around a bug in stdbool.h
- @${SED} -e 's:__STDC_VERSION__ < 199901L.*:__STDC_VERSION__ < 199901L \&\& defined(__GNUC__) \&\& __GNUC__ < 3 \&\& !defined(__INTEL_COMPILER):g' \
- </usr/include/stdbool.h \
- >${WRKSRC}/opt/${COMPILERDIR}/include/stdbool.h
-.endif
-.if ( ${OSVERSION} >= 500042 )
OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
--redefine-sym stdout=__stdoutp \
--redefine-sym stderr=__stderrp
-.endif
do-build:
# Use the Linux ABI for the binaries
@@ -196,14 +150,6 @@ do-build:
# Fix unresolved references
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/assert_fail.c \
${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
-.if ( ${OSVERSION} < 502101 )
- @cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c
-.endif
-.if ( ${OSVERSION} < 500042 )
- @${CC} ${CFLAGS} -c -o ${WRKSRC}/stdin.o ${FILESDIR}/stdin.c
- @${CC} ${CFLAGS} -c -o ${WRKSRC}/stdout.o ${FILESDIR}/stdout.c
- @${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c
-.endif
.for i in libcxa.a libcxaguard.a libimf.a libirc.a libirc_s.a libsvml.a \
libunwind.a
@${OBJCOPY} --redefine-sym __sigsetjmp=sigsetjmp \