aboutsummaryrefslogtreecommitdiff
path: root/lang/ifc7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ifc7/Makefile')
-rw-r--r--lang/ifc7/Makefile41
1 files changed, 23 insertions, 18 deletions
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index 6b95d54442b7..d663c20a4e86 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -1,64 +1,69 @@
-# New ports collection makefile for: ifc
-# Date created: Oct 30, 2001
-# Whom: chat95@mbox.kyoto-inet.or.jp
+# New ports collection makefile for: ifc
+# Date created: Oct 30, 2001
+# Whom: chat95@mbox.kyoto-inet.or.jp
#
# $FreeBSD$
#
PORTNAME= ifc
-PORTVERSION= 6.0.140
-CATEGORIES= lang linux
-MASTER_SITES= http://developer.intel.com/software/products/compilers/downloads/l_fc_p_6.0.140.htm
-DISTNAME= l_fc_p_6.0.140
+PORTVERSION= 6.0.159
+CATEGORIES= lang devel emulators linux
+MASTER_SITES=#
+DISTNAME= l_fc_pu_6.0.159
EXTRACT_SUFX= .tar
MAINTAINER= chat95@mbox.kyoto-inet.or.jp
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.2.2.so:${PORTSDIR}/emulators/linux_base
BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio \
${LINUXBASE}/usr/bin/cc:${PORTSDIR}/devel/linux_devtools-7
-RESTRICTED= "Redistribution not allowed"
+RESTRICTED= Intel forbids any redistribution
NO_PACKAGE= ${RESTRICTED}
NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
-#USE_LINUX= yes
+USE_LINUX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
+IFC_SITE= http://www.intel.com/software/products/compilers/
+
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= "Please manually download the version for RedHat 7.1 from ${MASTER_SITES}, e.g. from http://developer.intel.com/software/products/compilers/f60l/noncom.htm. Put it into ${DISTDIR} and run make again."
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= "Please manually download ${DISTFILES} from ${IFC_SITE}, e.g. from https://premier.intel.com/. Registration is required!! Put it into ${DISTDIR} and run make again."
.endif
post-extract:
.for i in \
- intel-ifc6-6.0-140.i386.rpm \
-# intel-ildb6-6.0-191.i386.rpm \
-# intel-efc6-6.0-140.ia64.rpm \
-# intel-eldb6-6.0-191.ia64.rpm
+ intel-ifc6-6.0-159.i386.rpm \
+# intel-ildb6-6.0-229.i386.rpm \
+# intel-efc6-6.0-159.ia64.rpm \
+# intel-eldb6-6.0-229.ia64.rpm
@cd ${WRKSRC}; rpm2cpio ${i} | cpio -idu --quiet
.endfor
pre-patch:
+# Allow everyone to use it
@${CHMOD} a+rx ${WRKSRC}/opt
+# Remove unneded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/compiler60/${i} -type f -print0 | \
xargs -0 ${CHMOD} a-x,g-w
.endfor
@${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+# Use the Linux ABI for the binaries
.for i in INTEL f90com fpp icid ifcbin ifccem lmgrd.intel lmutil profmerge proforder xiar xild
@brandelf -t Linux ${WRKSRC}/opt/intel/compiler60/ia32/bin/${i}
.endfor
post-patch:
+# Correct some paths and patch some files
.for i in ia32/bin/ifcvars.csh ia32/bin/ifcvars.sh \
- ia32/bin/ifc ia32/bin/ifc.pcl
- @${SED} 's@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@; s@man -w@manpath@ ; s@/bin/sh@${LINUXBASE}/bin/sh@' \
+ ia32/bin/ifc #ia32/bin/ifc.pcl
+ @${SED} 's@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@; s@man -w@manpath@ ; s@/bin/sh@${LINUXBASE}/bin/bash@' \
${WRKSRC}/opt/intel/compiler60/${i} \
>${WRKSRC}/opt/intel/compiler60/${i}.seded
@${MV} -f ${WRKSRC}/opt/intel/compiler60/${i}.seded \