aboutsummaryrefslogtreecommitdiff
path: root/lang/ifc7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ifc7/Makefile')
-rw-r--r--lang/ifc7/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index 378f7597a6c8..7e110368d0b3 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -105,8 +105,7 @@ post-patch:
.endfor
@cd ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ && ${LN} -s ifc.cfg ifcbin.cfg
-.if ( ${OSVERSION} >= 470101 && ${OSVERSION} < 500000 ) || \
- ( ${OSVERSION} >= 500042 )
+.if ( ${OSVERSION} >= 500042 )
OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
--redefine-sym stdout=__stdoutp \
--redefine-sym stderr=__stderrp
@@ -122,8 +121,7 @@ do-build:
.if ( ${OSVERSION} < 502101 )
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c
.endif
-.if ( ${OSVERSION} < 470101 ) || \
- ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500042 )
+.if ( ${OSVERSION} < 500042 )
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stdin.o ${FILESDIR}/stdin.c
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stdout.o ${FILESDIR}/stdout.c
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c