aboutsummaryrefslogtreecommitdiff
path: root/lang/io
diff options
context:
space:
mode:
Diffstat (limited to 'lang/io')
-rw-r--r--lang/io/Makefile19
-rw-r--r--lang/io/Makefile.addons56
-rw-r--r--lang/io/pkg-descr2
3 files changed, 41 insertions, 36 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index de928261cbf2..c8ec5ab7bcf3 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -11,9 +11,15 @@ COMMENT= Small prototype-based programming language
LICENSE= BSD
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_GROUP= ADDONS
+
+USE_GCC= yes
USE_GITHUB= yes
GH_ACCOUNT= stevedekorte
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 23afbcc
+MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= yes
USES= cmake:outsource
@@ -21,7 +27,6 @@ USES= cmake:outsource
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
.include "${.CURDIR}/Makefile.addons"
post-patch:
@@ -33,13 +38,13 @@ post-patch:
${FIND} ${WRKSRC}/addons -name "*.bak" -o -name "*.orig" -delete
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index b4e0bb0d1a75..52be436d5820 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -68,7 +68,7 @@ OPTIONAL_ADDONS=BigNum \
Vorbis \
Yajl
-OPTIONS_DEFINE= ${OPTIONAL_ADDONS}
+OPTIONS_GROUP_ADDONS=${OPTIONAL_ADDONS}
.include <bsd.port.options.mk>
@@ -76,35 +76,35 @@ OPTIONS_DEFINE= ${OPTIONAL_ADDONS}
# BigNum
#
.if ${PORT_OPTIONS:MBigNum}
-LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
.endif
#
# CFFI
#
.if ${PORT_OPTIONS:MCFFI}
-LIB_DEPENDS+= ffi:${PORTSDIR}/devel/libffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
.endif
#
# Clutter
#
.if ${PORT_OPTIONS:MClutter}
-LIB_DEPENDS+= clutter-glx-1.0:${PORTSDIR}/graphics/clutter
+LIB_DEPENDS+= libclutter-glx-1.0.so:${PORTSDIR}/graphics/clutter
.endif
#
# DBI
#
.if ${PORT_OPTIONS:MDBI}
-LIB_DEPENDS+= dbi:${PORTSDIR}/databases/libdbi
+LIB_DEPENDS+= libdbi.so:${PORTSDIR}/databases/libdbi
.endif
#
# EditLine
#
.if ${PORT_OPTIONS:MEditLine}
-LIB_DEPENDS+= edit:${PORTSDIR}/devel/libedit
+LIB_DEPENDS+= libedit.so:${PORTSDIR}/devel/libedit
.endif
#
@@ -113,37 +113,37 @@ LIB_DEPENDS+= edit:${PORTSDIR}/devel/libedit
.if ${PORT_OPTIONS:MFont}
USE_GL+= glut
USE_XORG+= xmu
-LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
.endif
#
# GLFW
#
.if ${PORT_OPTIONS:MGLFW}
-LIB_DEPENDS+= glfw:${PORTSDIR}/graphics/glfw
+LIB_DEPENDS+= libglfw.so.0:${PORTSDIR}/graphics/glfw
.endif
#
# Image
#
.if ${PORT_OPTIONS:MImage}
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
.endif
#
# LZO
#
.if ${PORT_OPTIONS:MLZO}
-LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= liblzo2.so:${PORTSDIR}/archivers/lzo2
.endif
#
# LibSndFile
#
.if ${PORT_OPTIONS:MLibSndFile}
-LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS+= libsndfile.so:${PORTSDIR}/audio/libsndfile
.endif
#
@@ -157,14 +157,14 @@ USE_GNOME+= libxml2
# Loudmouth
#
.if ${PORT_OPTIONS:MLoudmouth}
-LIB_DEPENDS+= loudmouth-1:${PORTSDIR}/net-im/loudmouth
+LIB_DEPENDS+= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
.endif
#
# Memcached
#
.if ${PORT_OPTIONS:MMemcached}
-LIB_DEPENDS+= memcached:${PORTSDIR}/databases/libmemcached
+LIB_DEPENDS+= libmemcached.so:${PORTSDIR}/databases/libmemcached
.endif
#
@@ -178,7 +178,7 @@ USE_MYSQL+= client
# Ogg
#
.if ${PORT_OPTIONS:MOgg}
-LIB_DEPENDS+= ogg:${PORTSDIR}/audio/libogg
+LIB_DEPENDS+= libogg.so:${PORTSDIR}/audio/libogg
.endif
#
@@ -208,21 +208,21 @@ USE_PYTHON= yes
# QDBM
#
.if ${PORT_OPTIONS:MQDBM}
-LIB_DEPENDS+= qdbm:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
.endif
#
# ReadLine
#
.if ${PORT_OPTIONS:MReadLine}
-LIB_DEPENDS+= history:${PORTSDIR}/devel/readline
+LIB_DEPENDS+= libhistory.so:${PORTSDIR}/devel/readline
.endif
#
# Regex
#
.if ${PORT_OPTIONS:MRegex}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
.endif
#
@@ -236,56 +236,56 @@ SQLITE_LIB= ${LOCALBASE}/lib/libsqlite${SQLITE_VER}.so
# SampleRateConverter
#
.if ${PORT_OPTIONS:MSampleRateConverter}
-LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
+LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
.endif
#
# Socket
#
.if ${PORT_OPTIONS:MSocket}
-LIB_DEPENDS+= event:${PORTSDIR}/devel/libevent
+LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent
.endif
#
# TagLib
#
.if ${PORT_OPTIONS:MTagLib}
-LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
+LIB_DEPENDS+= libtag.so:${PORTSDIR}/audio/taglib
.endif
#
# Theora
#
.if ${PORT_OPTIONS:MTheora}
-LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
+LIB_DEPENDS+= libtheora.so:${PORTSDIR}/multimedia/libtheora
.endif
#
# TokyoCabinet
#
.if ${PORT_OPTIONS:MTokyoCabinet}
-LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet
+LIB_DEPENDS+= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
.endif
#
# UUID
#
.if ${PORT_OPTIONS:MUUID}
-LIB_DEPENDS+= uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
+LIB_DEPENDS+= libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
.endif
#
# Vorbis
#
.if ${PORT_OPTIONS:MBVorbis}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.endif
#
# Yajl
#
.if ${PORT_OPTIONS:MYajl}
-LIB_DEPENDS+= yajl:${PORTSDIR}/devel/yajl
+LIB_DEPENDS+= libyajl.so:${PORTSDIR}/devel/yajl
.endif
@@ -296,7 +296,7 @@ LIB_DEPENDS+= yajl:${PORTSDIR}/devel/yajl
PLIST_SUB+= ${def}=""
.endfor
ADDONS= ${DEFAULT_ADDONS}
-.for opt in ${ALL_OPTIONS}
+.for opt in ${OPTIONS_GROUP_ADDONS}
. if defined (WITH_${opt})
ADDONS+= ${opt}
PLIST_SUB+= ${opt}=""
diff --git a/lang/io/pkg-descr b/lang/io/pkg-descr
index 911518346b76..081b5c62a830 100644
--- a/lang/io/pkg-descr
+++ b/lang/io/pkg-descr
@@ -4,4 +4,4 @@ are mostly inspired by Smalltalk (all values are objects), Self
(actors and futures for concurrency), LISP (code is a runtime
inspectable/modifiable tree) and Lua (small, embeddable).
-WWW: http://www.iolanguage.com/
+WWW: http://www.iolanguage.com/