aboutsummaryrefslogtreecommitdiff
path: root/lang/lua50
diff options
context:
space:
mode:
Diffstat (limited to 'lang/lua50')
-rw-r--r--lang/lua50/Makefile52
-rw-r--r--lang/lua50/distinfo2
-rw-r--r--lang/lua50/files/patch-ab20
-rw-r--r--lang/lua50/files/patch-config11
-rw-r--r--lang/lua50/pkg-descr21
-rw-r--r--lang/lua50/pkg-plist18
6 files changed, 0 insertions, 124 deletions
diff --git a/lang/lua50/Makefile b/lang/lua50/Makefile
deleted file mode 100644
index ca222ac39f8d..000000000000
--- a/lang/lua50/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# New ports collection makefile for: lua
-# Date created: 27 June 1999
-# Whom: Richard Kiss <him@richardkiss.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= lua
-PORTVERSION= 5.0.2
-PORTREVISION= 1
-CATEGORIES= lang
-MASTER_SITES= http://www.lua.org/ftp/ \
- ftp://ftp.tecgraf.puc-rio.br/pub/lua/ \
- ftp://csg.uwaterloo.ca/pub/lhf/lua/ \
- ftp://ftp.ntua.gr/pub/lang/lua/ \
- ftp://ftp.uni-trier.de/pub/languages/lua/ \
- ftp://ftp.gwdg.de/pub/languages/lua/
-
-MAINTAINER= him@richardkiss.com
-COMMENT= Small, compilable scripting language providing easy access to C code
-
-USE_REINPLACE= yes
-MAN1= lua.1 luac.1
-ALL_TARGET= all so
-INSTALL_TARGET= install soinstall
-INSTALLS_SHLIB= YES
-
-do-configure:
- ${REINPLACE_CMD} \
- -e 's|^\(MYCFLAGS=\).*$$|\1 ${CFLAGS}|' \
- -e 's|^\(LOADLIB=\).*$$|\1 -DUSE_DLOPEN=1|' \
- -e 's|^\(CC=\).*$$|\1 ${CC}|' \
- -e 's|^\(STRIP=\).*$$|\1 ${STRIP_CMD}|' \
- -e 's|^\(INSTALL_ROOT=\).*$$|\1 ${PREFIX}|' \
- -e 's|^\(INSTALL_EXEC=\).*$$|\1 ${INSTALL_PROGRAM}|' \
- -e 's|^\(INSTALL_DATA=\).*$$|\1 ${INSTALL_DATA}|' \
- -e 's|^#\(USERCONF.*READLINE.*\)$$|\1|' \
- -e 's|^\(EXTRA_LIBS=\).*$$|\1 -lm -lreadline -lhistory -lncurses|' \
- -e 's|V=5.0|V=5|' \
- ${WRKSRC}/config
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html *.gif ${DOCSDIR}
-.endif
-
-.if ${MACHINE_ARCH:L} == "amd64"
-CFLAGS+= -fPIC
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/lua50/distinfo b/lang/lua50/distinfo
deleted file mode 100644
index 77a8b267f158..000000000000
--- a/lang/lua50/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (lua-5.0.2.tar.gz) = dea74646b7e5c621fef7174df83c34b1
-SIZE (lua-5.0.2.tar.gz) = 190442
diff --git a/lang/lua50/files/patch-ab b/lang/lua50/files/patch-ab
deleted file mode 100644
index 5a24cd697f27..000000000000
--- a/lang/lua50/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/lib/lmathlib.c.orig Tue Mar 11 21:30:37 2003
-+++ src/lib/lmathlib.c Fri May 9 02:32:59 2003
-@@ -170,7 +170,7 @@
- static int math_random (lua_State *L) {
- /* the `%' avoids the (rare) case of r==1, and is needed also because on
- some systems (SunOS!) `rand()' may return a value larger than RAND_MAX */
-- lua_Number r = (lua_Number)(rand()%RAND_MAX) / (lua_Number)RAND_MAX;
-+ lua_Number r = (lua_Number)(random()%RAND_MAX) / (lua_Number)RAND_MAX;
- switch (lua_gettop(L)) { /* check number of arguments */
- case 0: { /* no arguments */
- lua_pushnumber(L, r); /* Number between 0 and 1 */
-@@ -196,7 +196,7 @@
-
-
- static int math_randomseed (lua_State *L) {
-- srand(luaL_checkint(L, 1));
-+ srandom(luaL_checkint(L, 1));
- return 0;
- }
-
diff --git a/lang/lua50/files/patch-config b/lang/lua50/files/patch-config
deleted file mode 100644
index af26d8b26550..000000000000
--- a/lang/lua50/files/patch-config
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.orig Fri Apr 11 16:00:41 2003
-+++ config Wed Jul 6 00:09:46 2005
-@@ -6,7 +6,7 @@
- LOADLIB=
- DLLIB=
- NUMBER=
--POPEN=
-+POPEN= -DUSE_POPEN=1
- TMPNAM=
- DEGREES=
- USERCONF=
diff --git a/lang/lua50/pkg-descr b/lang/lua50/pkg-descr
deleted file mode 100644
index d0ed8afbd09c..000000000000
--- a/lang/lua50/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-Lua is a programming language originally designed for extending applications,
-but also frequently used as a general-purpose, stand-alone language. Lua
-combines simple procedural syntax (similar to Pascal) with powerful data
-description constructs based on associative arrays and extensible semantics.
-Lua is dynamically typed, interpreted from bytecodes, and has automatic memory
-management with garbage collection, making it ideal for configuration,
-scripting, and rapid prototyping.
-
-A fundamental concept in the design of Lua is to provide meta-mechanisms for
-implementing features, instead of providing a host of features directly in
-the language. For example, although Lua is not a pure object-oriented
-language, it does provide meta-mechanisms for implementing classes and
-inheritance. Lua's meta-mechanisms bring an economy of concepts and keep the
-language small, while allowing the semantics to be extended in unconventional
-ways. Extensible semantics is a distinguishing feature of Lua.
-
-Lua is implemented as a small library of C functions, written in ANSI C, and
-compiles unmodified in all known platforms. The implementation goals are
-simplicity, efficiency, portability, and low embedding cost.
-
-WWW: http://www.lua.org/
diff --git a/lang/lua50/pkg-plist b/lang/lua50/pkg-plist
deleted file mode 100644
index ce4ed92536d9..000000000000
--- a/lang/lua50/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-bin/lua
-bin/luac
-include/lauxlib.h
-include/lua.h
-include/lualib.h
-lib/liblua.a
-lib/liblua.so
-lib/liblua.so.5
-lib/liblualib.a
-lib/liblualib.so
-lib/liblualib.so.5
-%%DOCSDIR%%/contents.html
-%%DOCSDIR%%/logo.gif
-%%DOCSDIR%%/lua.html
-%%DOCSDIR%%/luac.html
-%%DOCSDIR%%/manual.html
-%%DOCSDIR%%/readme.html
-@dirrm %%DOCSDIR%%