aboutsummaryrefslogtreecommitdiff
path: root/lang/mono/bsd.mono.mk
diff options
context:
space:
mode:
Diffstat (limited to 'lang/mono/bsd.mono.mk')
-rw-r--r--lang/mono/bsd.mono.mk40
1 files changed, 38 insertions, 2 deletions
diff --git a/lang/mono/bsd.mono.mk b/lang/mono/bsd.mono.mk
index 5c0f24f58281..7b20be853f3c 100644
--- a/lang/mono/bsd.mono.mk
+++ b/lang/mono/bsd.mono.mk
@@ -6,16 +6,20 @@
# the FreeBSD ports system.
#
# $FreeBSD$
-# $Id: bsd.mono.mk,v 1.12 2006/04/05 02:38:44 tmclau02 Exp $
+# $Id: bsd.mono.mk,v 1.15 2006/07/05 04:22:22 tmclau02 Exp $
#
+# USE_NANT - If set, the port uses nant.
+# USE_NANT - If set "contrib", the port uses nantcontrib.
+# NANT - Set to path of Nant.
+
# Set the location of the .wapi directory so we write to a location we
# can always assume to be writable.
MONO_SHARED_DIR=${WRKDIR}
CONFIGURE_ENV+=MONO_SHARED_DIR="${MONO_SHARED_DIR}"
MAKE_ENV+=MONO_SHARED_DIR="${MONO_SHARED_DIR}"
-# Set the location that webaps served bp XSP should use.
+# Set the location that webaps served by XSP should use.
XSP_DOCROOT=${PREFIX}/www/xsp
# Clean up the semaphore produced by the .wapi
@@ -24,3 +28,35 @@ pre-clean: mono-semdel
mono-semdel:
@${SETENV} G_DEBUG="" MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${LOCALBASE}/bin/mono-semdel 2> /dev/null || true
+
+
+# Dependencies
+
+.if defined(USE_NANT)
+BUILD_DEPENDS+= nant:${PORTSDIR}/devel/nant
+.if ${USE_NANT}=="contrib"
+BUILD_DEPENDS+= ${LOCALBASE}/share/NAnt/bin/NAnt.Contrib.Tests.dll:${PORTSDIR}/devel/nantcontrib
+.endif
+.endif
+
+# Miscellaneous overridable commands:
+
+NANT?= nant
+NANT_INSTALL_TARGET?= install
+
+# Build
+.if defined(USE_NANT)
+.if !target(do-build)
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${NANT} ${NANT_FLAGS})
+.endif
+.endif
+
+
+# Install
+.if defined(USE_NANT)
+.if !target(do-install)
+do-install:
+ @(cd ${INSTALL_WRKSRC}; ${SETENV} MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${NANT} ${NANT_FLAGS} -D:prefix="${PREFIX}" ${NANT_INSTALL_TARGET})
+.endif
+.endif