aboutsummaryrefslogtreecommitdiff
path: root/lang/nickle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/nickle/Makefile')
-rw-r--r--lang/nickle/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index 86a858dad7dc..58e7fded24e3 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nickle
-PORTVERSION= 2.72
+PORTVERSION= 2.73
CATEGORIES= lang
MASTER_SITES= http://www.nickle.org/release/
@@ -17,6 +17,7 @@ LICENSE= MIT
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
# Nickle now has bindings which are likely to pull in libraries that need
# libpthread. Link to it now explicitly, or it wouldn't work at runtime.
@@ -24,4 +25,19 @@ LDFLAGS+= ${PTHREAD_LIBS}
MAN1= nickle.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|examples|| ; \
+ s| -O2||' ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NIPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
+ -name "*.sgml" \) | ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} \
+ ${EXAMPLESDIR})
+ @${FIND} ${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
+ @${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endif
+
.include <bsd.port.mk>