aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml-camlidl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ocaml-camlidl/Makefile')
-rw-r--r--lang/ocaml-camlidl/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/ocaml-camlidl/Makefile b/lang/ocaml-camlidl/Makefile
index 898d973b0cc6..f8e03e11cc9f 100644
--- a/lang/ocaml-camlidl/Makefile
+++ b/lang/ocaml-camlidl/Makefile
@@ -26,6 +26,10 @@ DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+.if ${OSVERSION} < 500000
+USE_GMAKE= yes
+.endif
+
post-extract:
@${REINPLACE_CMD} -e "s,^\(OCAMLLIB=\).*,\1${PREFIX}/lib/ocaml,g" \
-e "s,^\(BINDIR=\).*,\1${PREFIX}/bin,g" \
@@ -51,8 +55,8 @@ pre-install:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${TAR} -C ${DOCSDIR} -xf \
- ${_DISTDIR}/${PORTNAME}-${PORTVERSION}.doc.html.tar.gz
+ ${GZCAT} ${_DISTDIR}/${PORTNAME}-${PORTVERSION}.doc.html.tar.gz \
+ | ${TAR} -C ${DOCSDIR} -xf -
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.endif