aboutsummaryrefslogtreecommitdiff
path: root/lang/ofc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ofc/Makefile')
-rw-r--r--lang/ofc/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 557481368414..25665eb905d2 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ofc
PORTVERSION= 0.8.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang
MASTER_SITES= http://ofc.dvoudheusden.net/download/
@@ -15,7 +15,7 @@ MAINTAINER= vanilla@FreeBSD.org
COMMENT= The Objective-C Foundation Classes library
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
@@ -24,7 +24,7 @@ USE_AUTOTOOLS= libtool
USE_GNOME= gnomehack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
OPTIONS= GDBM "Add gdbm support" off \
@@ -41,7 +41,15 @@ LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 900000
-BROKEN= does not compile on FreeBSD 9.X
+# needs libobjc
+GCCSUFFIX=42
+CC= gcc${GCCSUFFIX}
+CXX= g++${GCCSUFFIX}
+OFC_GCC_PORT?= lang/gcc${GCCSUFFIX}
+TARGLIB!= (cd ${PORTSDIR}/${OFC_GCC_PORT} && make -V TARGLIB)
+LDFLAGS+= -L${TARGLIB}
+BUILD_DEPENDS+= ${TARGLIB}/libobjc.so:${PORTSDIR}/${OFC_GCC_PORT}
+RUN_DEPENDS+= ${TARGLIB}/libobjc.so:${PORTSDIR}/${OFC_GCC_PORT}
.endif
.include <bsd.port.post.mk>