aboutsummaryrefslogtreecommitdiff
path: root/lang/ofc
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ofc')
-rw-r--r--lang/ofc/Makefile21
-rw-r--r--lang/ofc/files/patch-ofc__DJPEGImage.m10
-rw-r--r--lang/ofc/files/patch-ofc__DLog.m11
-rw-r--r--lang/ofc/files/patch-ofc__DTCPServer.m30
-rw-r--r--lang/ofc/files/patch-ofc__DText.m10
5 files changed, 66 insertions, 16 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 29655e535810..ad832f48fc05 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ofc
PORTVERSION= 0.8.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= lang
MASTER_SITES= GOOGLE_CODE
@@ -17,27 +17,16 @@ LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
PROJECTHOST= ${PORTNAME}
USE_SDL= sdl
-USES= libtool pathfix
+USES= libtool objc pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= GDBM GMP
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
-.endif
-
-.if ${PORT_OPTIONS:MGMP}
-LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
-.endif
-
-.if ${OSVERSION} >= 900000
-# 'obj/obj-api.h' deprecated on gcc4.7, so ofc require gcc4.6 or early version.
-USE_GCC= 4.6
-.endif
+GDBM_LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
+GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
.include <bsd.port.mk>
diff --git a/lang/ofc/files/patch-ofc__DJPEGImage.m b/lang/ofc/files/patch-ofc__DJPEGImage.m
new file mode 100644
index 000000000000..cfcdc174165d
--- /dev/null
+++ b/lang/ofc/files/patch-ofc__DJPEGImage.m
@@ -0,0 +1,10 @@
+--- ./ofc/DJPEGImage.m.orig 2008-08-20 19:16:29.000000000 +0200
++++ ./ofc/DJPEGImage.m 2014-08-29 08:26:49.885998054 +0200
+@@ -25,6 +25,7 @@
+ //==============================================================================
+
+ #include <setjmp.h>
++#include <stdio.h>
+
+ #include "ofc/DJPEGImage.h"
+
diff --git a/lang/ofc/files/patch-ofc__DLog.m b/lang/ofc/files/patch-ofc__DLog.m
new file mode 100644
index 000000000000..6f20d98f6303
--- /dev/null
+++ b/lang/ofc/files/patch-ofc__DLog.m
@@ -0,0 +1,11 @@
+--- ./ofc/DLog.m.orig 2004-11-23 21:06:33.000000000 +0100
++++ ./ofc/DLog.m 2014-08-29 08:26:49.886998482 +0200
+@@ -25,7 +25,7 @@
+ //==============================================================================
+
+ #include "ofc/DLog.h"
+-
++#include <stdarg.h>
+
+ #if _INTERFACE_
+
diff --git a/lang/ofc/files/patch-ofc__DTCPServer.m b/lang/ofc/files/patch-ofc__DTCPServer.m
new file mode 100644
index 000000000000..be3fad93f8c4
--- /dev/null
+++ b/lang/ofc/files/patch-ofc__DTCPServer.m
@@ -0,0 +1,30 @@
+--- ./ofc/DTCPServer.m.orig 2008-08-11 18:59:46.000000000 +0200
++++ ./ofc/DTCPServer.m 2014-08-29 08:26:49.887997880 +0200
+@@ -370,6 +370,7 @@
+ {
+ switch(_mode)
+ {
++#ifndef __FreeBSD__
+ case DTS_THREADING:
+ {
+ ok = (objc_thread_detach(@selector(handleConnection:), self, peer) != NULL);
+@@ -380,6 +381,7 @@
+ }
+ }
+ break;
++#endif
+ #ifndef WIN32
+ case DTS_FORKING:
+ {
+@@ -460,9 +462,11 @@
+
+ switch(_mode)
+ {
++#ifndef __FreeBSD__
+ case DTS_THREADING:
+ objc_thread_exit();
+ break;
++#endif
+
+ case DTS_FORKING:
+ exit(0);
diff --git a/lang/ofc/files/patch-ofc__DText.m b/lang/ofc/files/patch-ofc__DText.m
new file mode 100644
index 000000000000..595594c51973
--- /dev/null
+++ b/lang/ofc/files/patch-ofc__DText.m
@@ -0,0 +1,10 @@
+--- ./ofc/DText.m.orig 2008-08-05 18:29:04.000000000 +0200
++++ ./ofc/DText.m 2014-08-29 08:27:25.604995394 +0200
+@@ -29,6 +29,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <stdlib.h>
++#include <stdarg.h>
+ #include <errno.h>
+ #include <stdio.h>
+