aboutsummaryrefslogtreecommitdiff
path: root/lang/oorexx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/oorexx/Makefile')
-rw-r--r--lang/oorexx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/oorexx/Makefile b/lang/oorexx/Makefile
new file mode 100644
index 000000000000..54c4d961900c
--- /dev/null
+++ b/lang/oorexx/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ooRexx
+# Date created: 04 Jun 2005
+# Whom: Micho
+#
+# $FreeBSD$
+#
+
+PORTNAME= oorexx
+PORTVERSION= 3.0.0
+CATEGORIES= lang
+MASTER_SITES= http://www.matem.unam.mx/~micho/download/
+
+MAINTAINER= micho@matem.unam.mx
+COMMENT= A powerful typeless object-oriented scripting language
+
+CONFLICTS= rexx-regina-[0-9]*
+
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+MAKE_ENV= EXAMPLESDIR="${EXAMPLESDIR}"
+MAN1= rexx.1 rexxc.1 rxmigrate.1 rxsubcom.1 rxqueue.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|; \
+ s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local/oorexx|${PREFIX}/lib/oorexx|' \
+ ${WRKSRC}/rxtests/README
+
+.include <bsd.port.mk>