aboutsummaryrefslogtreecommitdiff
path: root/lang/open-cobol-devel
diff options
context:
space:
mode:
Diffstat (limited to 'lang/open-cobol-devel')
-rw-r--r--lang/open-cobol-devel/Makefile43
-rw-r--r--lang/open-cobol-devel/distinfo2
-rw-r--r--lang/open-cobol-devel/files/patch-cobc::cobc.c11
-rw-r--r--lang/open-cobol-devel/files/patch-config::ltmain.sh15
-rw-r--r--lang/open-cobol-devel/files/patch-lib::Makefile.in20
-rw-r--r--lang/open-cobol-devel/files/patch-libcob::fileio.c20
-rw-r--r--lang/open-cobol-devel/files/patch-libcob::screenio.c10
-rw-r--r--lang/open-cobol-devel/pkg-descr4
-rw-r--r--lang/open-cobol-devel/pkg-plist18
9 files changed, 0 insertions, 143 deletions
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
deleted file mode 100644
index 1dee18e1a35c..000000000000
--- a/lang/open-cobol-devel/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: open-cobol
-# Date created: Aug 6, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= open-cobol
-PORTVERSION= 0.23
-PORTREVISION= 1
-CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An open-source COBOL compiler
-
-LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl \
- gmp.6:${PORTSDIR}/math/libgmp4
-
-USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-readline
-INSTALLS_SHLIB= yes
-
-INFO= open-cobol
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-LDFLAGS+= -lintl
-PLIST_SUB+= NLS=""
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/open-cobol-devel/distinfo b/lang/open-cobol-devel/distinfo
deleted file mode 100644
index de026d8c1ef0..000000000000
--- a/lang/open-cobol-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (open-cobol-0.23.tar.gz) = a253ca8965dd071c517d3860e9730137
-SIZE (open-cobol-0.23.tar.gz) = 658911
diff --git a/lang/open-cobol-devel/files/patch-cobc::cobc.c b/lang/open-cobol-devel/files/patch-cobc::cobc.c
deleted file mode 100644
index d1809c280868..000000000000
--- a/lang/open-cobol-devel/files/patch-cobc::cobc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- cobc/cobc.c.orig Thu Jun 5 09:02:15 2003
-+++ cobc/cobc.c Sun Apr 4 00:32:21 2004
-@@ -36,7 +36,7 @@
-
- #include "cobc.h"
- #include "tree.h"
--#include "lib/getopt.h"
-+#include <getopt.h>
-
-
- /*
diff --git a/lang/open-cobol-devel/files/patch-config::ltmain.sh b/lang/open-cobol-devel/files/patch-config::ltmain.sh
deleted file mode 100644
index c1404aef33c2..000000000000
--- a/lang/open-cobol-devel/files/patch-config::ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/ltmain.sh.orig Fri Nov 22 17:03:54 2002
-+++ config/ltmain.sh Thu Dec 12 20:35:02 2002
-@@ -4280,10 +4280,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/lang/open-cobol-devel/files/patch-lib::Makefile.in b/lang/open-cobol-devel/files/patch-lib::Makefile.in
deleted file mode 100644
index 56255ffbdb28..000000000000
--- a/lang/open-cobol-devel/files/patch-lib::Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/Makefile.in.orig Thu Jun 12 05:13:50 2003
-+++ lib/Makefile.in Sun Apr 4 00:28:58 2004
-@@ -175,7 +175,7 @@
- DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
- depcomp = $(SHELL) $(top_srcdir)/config/depcomp
- am__depfiles_maybe = depfiles
--@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Po $(DEPDIR)/getopt1.Po \
-+@AMDEP_TRUE@DEP_FILES = \
- @AMDEP_TRUE@ $(DEPDIR)/malloc.Po $(DEPDIR)/memcmp.Po \
- @AMDEP_TRUE@ $(DEPDIR)/realloc.Po
- COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
-@@ -215,8 +215,6 @@
- distclean-compile:
- -rm -f *.tab.c
-
--@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Po@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/malloc.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/memcmp.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/realloc.Po@am__quote@
diff --git a/lang/open-cobol-devel/files/patch-libcob::fileio.c b/lang/open-cobol-devel/files/patch-libcob::fileio.c
deleted file mode 100644
index d96315e95d73..000000000000
--- a/lang/open-cobol-devel/files/patch-libcob::fileio.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- libcob/fileio.c.orig Wed Jun 11 15:40:20 2003
-+++ libcob/fileio.c Wed Aug 27 09:57:31 2003
-@@ -202,13 +202,10 @@
- else
- {
- /* discard input until the next newline */
-- int c = getc (f->file);
-- while (c != '\r' && c != '\n' && c != EOF)
-- c = getc (f->file);
-- if (c == '\r')
-- c = getc (f->file);
-- if (c != '\n' && c != EOF)
-- ungetc (c, f->file);
-+ char buff[BUFSIZ];
-+ while (fgets (buff, BUFSIZ, f->file) !=NULL)
-+ if (strchr (buff, '\n') != NULL)
-+ break;
- }
-
- memcpy (f->record->data, buff, f->record->size);
diff --git a/lang/open-cobol-devel/files/patch-libcob::screenio.c b/lang/open-cobol-devel/files/patch-libcob::screenio.c
deleted file mode 100644
index 31e83902355b..000000000000
--- a/lang/open-cobol-devel/files/patch-libcob::screenio.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libcob/screenio.c.orig Thu Apr 3 06:02:51 2003
-+++ libcob/screenio.c Tue Apr 29 04:09:44 2003
-@@ -19,6 +19,7 @@
-
- #include "config.h"
-
-+#include <sys/types.h>
- #include <string.h>
- #if HAVE_CURSES_H
- #include <curses.h>
diff --git a/lang/open-cobol-devel/pkg-descr b/lang/open-cobol-devel/pkg-descr
deleted file mode 100644
index b2a60776171f..000000000000
--- a/lang/open-cobol-devel/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-OpenCOBOL is an open-source COBOL compiler, which translates COBOL programs
-o C code and compiles it using GCC.
-
-WWW: http://open-cobol.sourceforge.net/
diff --git a/lang/open-cobol-devel/pkg-plist b/lang/open-cobol-devel/pkg-plist
deleted file mode 100644
index 630de4906766..000000000000
--- a/lang/open-cobol-devel/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-bin/cob-config
-bin/cobc
-etc/libcob.conf
-include/libcob.h
-include/libcob/call.h
-include/libcob/common.h
-include/libcob/exception.def
-include/libcob/fileio.h
-include/libcob/move.h
-include/libcob/numeric.h
-include/libcob/screenio.h
-include/libcob/strings.h
-include/libcob/termio.h
-lib/libcob.a
-lib/libcob.so
-lib/libcob.so.1
-%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
-@dirrm include/libcob