aboutsummaryrefslogtreecommitdiff
path: root/lang/open-cobol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/open-cobol/Makefile')
-rw-r--r--lang/open-cobol/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 67376c026464..f61e0eb29e25 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -7,27 +7,25 @@
#
PORTNAME= open-cobol
-PORTVERSION= 0.32
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An open-source COBOL compiler
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
-USE_GETOPT_LONG=yes
-USE_AUTOTOOLS= libltdl:15 libtool:15
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnometarget
+USE_BDB= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INFO= open-cobol
-CPPFLAGS= -I${LOCALBASE}/include
+CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
.if defined(WITHOUT_NLS)
@@ -39,12 +37,8 @@ PLIST_SUB+= NLS=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|__gmp_rand|__gmpz_init|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
- ${WRKSRC}/cobc/Makefile.in
+ @${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
+ s|db-4.[0-9]|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
.if defined(MAINTAINER_MODE)
test: build