aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-v6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/p5-v6/Makefile')
-rw-r--r--lang/p5-v6/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/p5-v6/Makefile b/lang/p5-v6/Makefile
new file mode 100644
index 000000000000..13fd7201ee07
--- /dev/null
+++ b/lang/p5-v6/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# Ports collection makefile for: v6
+# Date created: Aug 1, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= v6
+PORTVERSION= 0.011
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/C/CL/CLKAO
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-alpha-${PORTVERSION}
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= An experimental compiler for Perl 6
+
+BUILD_DEPENDS= p5-Data-Bind>=0.28:${PORTSDIR}/devel/p5-Data-Bind \
+ p5-Devel-Caller>=0.10:${PORTSDIR}/devel/p5-Devel-Caller \
+ p5-Module-Compile>=0.17:${PORTSDIR}/devel/p5-Module-Compile \
+ p5-Moose>=0.10:${PORTSDIR}/devel/p5-Moose \
+ p5-Pugs-Compiler-Rule>=0.12:${PORTSDIR}/lang/p5-Pugs-Compiler-Rule \
+ p5-Sub-Multi>=0:${PORTSDIR}/devel/p5-Sub-Multi
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= v6.3 \
+ Pugs::Compiler::Perl6.3 \
+ Pugs::Runtime::Perl6.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>