aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.10/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/perl5.10/Makefile')
-rw-r--r--lang/perl5.10/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index ec6a3d6cd0bc..d2c14bf05ddd 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
CONFIGURE_ARGS+= -Dusemymalloc=n
.endif
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= -Dusethreads=y
+PKGNAMESUFFIX= -threaded
+.else
+CONFIGURE_ARGS+= -Dusethreads=n
+.endif
+
INCLUDEDIR= /usr/include
.include <bsd.port.pre.mk>