aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/perl5.14/Makefile')
-rw-r--r--lang/perl5.14/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 4a7cf88df437..46c7d47d3b4e 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -146,6 +146,7 @@ pre-fetch:
@${ECHO} " (affects only 32-bit platforms)."
@${ECHO} " WITH_THREADS=yes Build threaded perl."
@${ECHO} " ENABLE_SUIDPERL=yes Also build set-user-id suidperl binary."
+ @${ECHO} " WITHOUT_USE_PERL=yes Do not rewrite links in /usr/bin"
@${ECHO} ""
post-patch:
@@ -187,11 +188,13 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
+.ifndef WITHOUT_USE_PERL
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
+.endif
rebuild-xs:
${LOCALBASE}/sbin/portupgrade -f `(${FIND} ${PKG_DBDIR}/p5*/+CONTENTS | \