aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14
diff options
context:
space:
mode:
Diffstat (limited to 'lang/perl5.14')
-rw-r--r--lang/perl5.14/Makefile7
-rw-r--r--lang/perl5.14/files/patch-ac15
2 files changed, 20 insertions, 2 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index ec6a3d6cd0bc..d2c14bf05ddd 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
CONFIGURE_ARGS+= -Dusemymalloc=n
.endif
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= -Dusethreads=y
+PKGNAMESUFFIX= -threaded
+.else
+CONFIGURE_ARGS+= -Dusethreads=n
+.endif
+
INCLUDEDIR= /usr/include
.include <bsd.port.pre.mk>
diff --git a/lang/perl5.14/files/patch-ac b/lang/perl5.14/files/patch-ac
index 313b7d4b48f2..f7255c5d354c 100644
--- a/lang/perl5.14/files/patch-ac
+++ b/lang/perl5.14/files/patch-ac
@@ -1,7 +1,8 @@
+
$FreeBSD$
---- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
-+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
+--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
++++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
@@ -98,6 +98,13 @@
;;
esac
@@ -25,3 +26,13 @@ $FreeBSD$
;;
esac
+@@ -223,6 +230,9 @@
+ 4.*) # 4.x has gethostbyaddr_r but it is
+ # "Temporary function, not threadsafe"...
+ d_gethostbyaddr_r="undef"
++ d_gethostbyaddr_r_proto="undef"
++ ;;
++ 5.*) d_gethostbyaddr_r="undef"
+ d_gethostbyaddr_r_proto="undef"
+ ;;
+ esac