aboutsummaryrefslogtreecommitdiff
path: root/lang/php4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php4/Makefile')
-rw-r--r--lang/php4/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 4a057e506312..7c9b91f80db9 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -67,8 +67,11 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
- ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
+WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
+
+CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \