aboutsummaryrefslogtreecommitdiff
path: root/lang/php5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5/Makefile')
-rw-r--r--lang/php5/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 200cb723b10a..c53f32b7a13b 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.0.1
+PORTVERSION= 5.0.2
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
@@ -111,12 +111,8 @@ SAPI_FILE= bin/php
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500016
-WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
-WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
- ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
-.endif
+CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
.if defined(WITH_APACHE)
.if exists(${LOCALBASE}/include/apache2/httpd.h)
@@ -172,6 +168,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
+ @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g" ${WRKSRC}/configure
.if ${PHP_SAPI} == "full"
pre-configure: