aboutsummaryrefslogtreecommitdiff
path: root/lang/php5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5/Makefile')
-rw-r--r--lang/php5/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index b0354884ee5b..930ef84e5aa5 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.6
-PORTREVISION?= 2
+PORTVERSION= 5.2.8
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -22,12 +22,16 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf:262
+# use bundled pcre while apache2 does the same
+#LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
CONFIGURE_ARGS= \
--with-layout=GNU \
--with-config-file-scan-dir=${PREFIX}/etc/php \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --with-pcre-regex=yes \
--enable-reflection \
--program-prefix=""
@@ -55,7 +59,8 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.2.patch.gz:suhosin
+#PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.3.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-5.2.7-0.9.6.3.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
@@ -63,7 +68,8 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+PATCHFILES+= php-5.2.6-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -158,6 +164,10 @@ post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
+ @${ECHO_CMD} "PHP_EXT_INC=pcre" >> ${WRKDIR}/php.conf
+
+test: build
+ @(cd ${WRKSRC} && ${MAKE} test)
post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc