aboutsummaryrefslogtreecommitdiff
path: root/lang/php53/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php53/Makefile')
-rw-r--r--lang/php53/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 7beaceb2cf45..db9c68378afb 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.8
+PORTVERSION= 5.2.9
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
@@ -22,16 +22,12 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf:262
-# use bundled pcre while apache2 does the same
-#LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-
CONFIGURE_ARGS= \
--with-layout=GNU \
--with-config-file-scan-dir=${PREFIX}/etc/php \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
- --with-pcre-regex=yes \
--enable-reflection \
--program-prefix=""
@@ -59,8 +55,7 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-#PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.3.patch.gz:suhosin
-PATCHFILES+= suhosin-patch-5.2.7-0.9.6.3.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.7.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
@@ -68,7 +63,8 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+PATCHFILES+= php-5.2.8-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -163,10 +159,6 @@ post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
- @${ECHO_CMD} "PHP_EXT_INC=pcre" >> ${WRKDIR}/php.conf
-
-test: build
- @(cd ${WRKSRC} && ${MAKE} test)
post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc