aboutsummaryrefslogtreecommitdiff
path: root/lang/php56/Makefile.ext
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php56/Makefile.ext')
-rw-r--r--lang/php56/Makefile.ext68
1 files changed, 34 insertions, 34 deletions
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 8ed5295444be..fec5aff98418 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -502,6 +502,40 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.if ${PHP_MODNAME} == "mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysql=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "mysqli"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysqli=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
+
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "pdo_mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
+
+USE_PHP+= mysql
+. else
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USES+= mysql
+. endif
+.endif
+
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "gd"
@@ -545,27 +579,6 @@ CONFIGURE_ARGS+=--disable-mbregex
. endif
.endif
-.if ${PHP_MODNAME} == "mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysql=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
-.if ${PHP_MODNAME} == "mysqli"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysqli=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
@@ -579,19 +592,6 @@ LIB_DEPENDS+= libct.so:databases/freetds
. endif
.endif
-.if ${PHP_MODNAME} == "pdo_mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-
-USE_PHP+= mysql
-. else
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "xml"
post-extract:
@${MKDIR} ${WRKSRC}/ext/xml