aboutsummaryrefslogtreecommitdiff
path: root/lang/python23/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python23/Makefile')
-rw-r--r--lang/python23/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
new file mode 100644
index 000000000000..a8ea89a2cc8d
--- /dev/null
+++ b/lang/python23/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: python
+# Version required: 1.2
+# Date created: 08 August 1995
+# Whom: jkh
+#
+# $Id$
+#
+
+DISTNAME= python1.2
+CATEGORIES+= languages
+MASTER_SITES= ftp://www.python.org/pub/python/src/
+
+MAINTAINER= jkh@FreeBSD.org
+WRKSRC= ${WRKDIR}/Python-1.2
+HAS_CONFIGURE= yes
+
+LIB_DEPENDS= tcl\\.7\\.:${PORTSDIR}/lang/tcl \
+ tk\\.3\\.:${PORTSDIR}/x11/tk
+
+post-configure:
+ cp ${FILESDIR}/Setup ${WRKSRC}/Modules
+
+pre-install:
+ cd ${WRKSRC}; ${MAKE} libinstall
+
+.include <bsd.port.mk>