aboutsummaryrefslogtreecommitdiff
path: root/lang/python24/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python24/Makefile')
-rw-r--r--lang/python24/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index e0ddbf78e425..386618c09faf 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -71,6 +70,9 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
+.if ${ARCH} == amd64
+CFLAGS+= -fPIC
+.endif
.if ${OSVERSION} < 400000
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
@@ -111,6 +113,10 @@ post-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
+ ${REINPLACE_CMD} -e \
+ 's,^#\(dl .*\),\1,' ${WRKSRC}/Modules/Setup.dist
+.endif
pre-install:
.for platform in ${PLATFORMS}