aboutsummaryrefslogtreecommitdiff
path: root/lang/python24/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python24/files/patch-setup.py')
-rw-r--r--lang/python24/files/patch-setup.py64
1 files changed, 0 insertions, 64 deletions
diff --git a/lang/python24/files/patch-setup.py b/lang/python24/files/patch-setup.py
deleted file mode 100644
index 0b578c9ec329..000000000000
--- a/lang/python24/files/patch-setup.py
+++ /dev/null
@@ -1,64 +0,0 @@
---- setup.py.orig Fri Mar 30 04:28:05 2007
-+++ setup.py Fri Mar 30 04:30:54 2007
-@@ -15,7 +15,7 @@
- from distutils.command.install_lib import install_lib
-
- # This global variable is used to hold the list of modules to be disabled.
--disabled_module_list = []
-+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz"]
-
- def add_dir_to_list(dirlist, dir):
- """Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -442,7 +442,7 @@
- if self.compiler.find_library_file(lib_dirs, 'readline'):
- readline_libs = ['readline']
- if self.compiler.find_library_file(lib_dirs,
-- 'ncursesw'):
-+ 'xxxncursesw'):
- readline_libs.append('ncursesw')
- elif self.compiler.find_library_file(lib_dirs,
- 'ncurses'):
-@@ -465,7 +465,7 @@
- readline_extra_link_args = ()
-
- exts.append( Extension('readline', ['readline.c'],
-- library_dirs=['/usr/lib/termcap'],
-+ library_dirs=['/usr/lib', '/usr/lib/termcap'],
- extra_link_args=readline_extra_link_args,
- libraries=readline_libs) )
- if platform not in ['mac']:
-@@ -728,7 +728,7 @@
- # Curses support, requiring the System V version of curses, often
- # provided by the ncurses library.
- panel_library = 'panel'
-- if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
-+ if (self.compiler.find_library_file(lib_dirs, 'xxxncursesw')):
- curses_libs = ['ncursesw']
- # Bug 1464056: If _curses.so links with ncursesw,
- # _curses_panel.so must link with panelw.
-@@ -738,6 +738,7 @@
- elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
- curses_libs = ['ncurses']
- exts.append( Extension('_curses', ['_cursesmodule.c'],
-+ library_dirs = ['/usr/lib'],
- libraries = curses_libs) )
- elif (self.compiler.find_library_file(lib_dirs, 'curses')
- and platform != 'darwin'):
-@@ -757,6 +758,7 @@
- if (module_enabled(exts, '_curses') and
- self.compiler.find_library_file(lib_dirs, panel_library)):
- exts.append( Extension('_curses_panel', ['_curses_panel.c'],
-+ library_dirs = ['/usr/lib'],
- libraries = [panel_library] + curses_libs) )
-
-
-@@ -1225,8 +1227,7 @@
- ext_modules=[Extension('struct', ['structmodule.c'])],
-
- # Scripts to install
-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
-- 'Lib/smtpd.py']
-+ scripts = []
- )
-
- # --install-platlib