aboutsummaryrefslogtreecommitdiff
path: root/lang/python24
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python24')
-rw-r--r--lang/python24/Makefile2
-rw-r--r--lang/python24/files/patch-Lib::distutils::spawn.py17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index cca1766771f9..516eac521283 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python24/files/patch-Lib::distutils::spawn.py b/lang/python24/files/patch-Lib::distutils::spawn.py
new file mode 100644
index 000000000000..208b10fc1083
--- /dev/null
+++ b/lang/python24/files/patch-Lib::distutils::spawn.py
@@ -0,0 +1,17 @@
+--- Lib/distutils/spawn.py.orig Tue Feb 24 16:55:44 2004
++++ Lib/distutils/spawn.py Tue Feb 24 16:56:01 2004
+@@ -144,7 +144,13 @@
+ # Loop until the child either exits or is terminated by a signal
+ # (ie. keep waiting if it's merely stopped)
+ while 1:
+- (pid, status) = os.waitpid(pid, 0)
++ try:
++ (pid, status) = os.waitpid(pid, 0)
++ except OSError, exc:
++ import errno
++ if exc.errno == errno.EINTR:
++ continue
++ raise exc
+ if os.WIFSIGNALED(status):
+ raise DistutilsExecError, \
+ "command '%s' terminated by signal %d" % \