aboutsummaryrefslogtreecommitdiff
path: root/lang/python26/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python26/Makefile')
-rw-r--r--lang/python26/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}