aboutsummaryrefslogtreecommitdiff
path: root/lang/python26
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python26')
-rw-r--r--lang/python26/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 0297063930e4..a27aa08f3d3d 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python26
PORTVERSION= 2.6.8
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,10 +51,10 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES
-OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+OPTIONS_DEFAULT= THREADS UCS2 PYMALLOC IPV6
OPTIONS_SINGLE= UCS
-OPTIONS_SINGLE_UCS= UCS4 UCS2
+OPTIONS_SINGLE_UCS= UCS2 UCS4
.include <bsd.port.pre.mk>
@@ -105,7 +106,7 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --enable-unicode=ucs2
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.endif