aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index b4a9a139cdea..6803069c26e8 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -6,7 +6,7 @@
PORTNAME= python27
PORTVERSION= 2.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -49,7 +49,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
SEM "Use POSIX semaphores (experimental)" off \
PTH "Use GNU Pth for threading/multiprocessing" off \
UCS4 "Use UCS4 for unicode support" on \
@@ -98,11 +97,6 @@ CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.endif # defined(WITH_PTH)
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "
CONFIGURE_ARGS+= --without-threads