aboutsummaryrefslogtreecommitdiff
path: root/lang/python30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python30/Makefile')
-rw-r--r--lang/python30/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 06e31e8b738e..3a8b9a65514d 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -39,8 +39,8 @@ SETUP_FILE= Setup
LIBC_R!= /sbin/ldconfig -r | grep c_r || true
.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
-CFLAGS+= -D_THREAD_SAFE
-CONFIGURE_ENV+= LDFLAGS="-pthread ${LDFLAGS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.endif