aboutsummaryrefslogtreecommitdiff
path: root/lang/python32/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python32/files/patch-setup.py')
-rw-r--r--lang/python32/files/patch-setup.py35
1 files changed, 17 insertions, 18 deletions
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index 7fc196bdf38f..740f3afec082 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2008-09-30 09:15:45.000000000 +0900
-+++ setup.py 2008-10-09 20:34:35.000000000 +0900
-@@ -17,7 +17,7 @@
+--- setup.py.orig 2009-06-28 20:59:53.170127518 +0800
++++ setup.py 2009-06-29 01:19:05.592053355 +0800
+@@ -16,7 +16,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
@@ -9,16 +9,16 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -575,7 +575,7 @@
+@@ -514,7 +514,7 @@
readline_libs = ['readline']
if self.compiler.find_library_file(lib_dirs,
- 'ncursesw'):
-+ 'xxxncursesw'):
++ 'XXXncursesw'):
readline_libs.append('ncursesw')
elif self.compiler.find_library_file(lib_dirs,
'ncurses'):
-@@ -587,7 +587,7 @@
+@@ -526,7 +526,7 @@
'termcap'):
readline_libs.append('termcap')
exts.append( Extension('readline', ['readline.c'],
@@ -27,25 +27,25 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -687,6 +687,8 @@
+@@ -619,6 +619,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
+ else:
+ open('.without_own_sha', 'w')
- # Modules that provide persistent dictionary-like semantics. You will
- # probably want to arrange for at least one of them to be available on
-@@ -1066,7 +1068,7 @@
+ if openssl_ver < 0x00907000:
+ # no openssl at all, use our own md5 and sha1
+@@ -994,7 +996,7 @@
# Curses support, requiring the System V version of curses, often
# provided by the ncurses library.
panel_library = 'panel'
- if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
-+ if (self.compiler.find_library_file(lib_dirs, 'xxxncursesw')):
++ if (self.compiler.find_library_file(lib_dirs, 'XXXncursesw')):
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1076,6 +1078,7 @@
+@@ -1004,6 +1006,7 @@
elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
curses_libs = ['ncurses']
exts.append( Extension('_curses', ['_cursesmodule.c'],
@@ -53,7 +53,7 @@
libraries = curses_libs) )
elif (self.compiler.find_library_file(lib_dirs, 'curses')
and platform != 'darwin'):
-@@ -1097,6 +1100,7 @@
+@@ -1025,6 +1028,7 @@
if (module_enabled(exts, '_curses') and
self.compiler.find_library_file(lib_dirs, panel_library)):
exts.append( Extension('_curses_panel', ['_curses_panel.c'],
@@ -61,13 +61,12 @@
libraries = [panel_library] + curses_libs) )
else:
missing.append('_curses_panel')
-@@ -1869,9 +1873,7 @@
+@@ -1666,8 +1670,7 @@
+ # called unless there's at least one extension module defined.
ext_modules=[Extension('_struct', ['_struct.c'])],
- # Scripts to install
-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
-- 'Tools/scripts/2to3',
-- 'Lib/smtpd.py']
+- scripts = ["Tools/scripts/pydoc3", "Tools/scripts/idle3",
+- "Tools/scripts/2to3"]
+ scripts = []
)