aboutsummaryrefslogtreecommitdiff
path: root/lang/python33/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python33/Makefile')
-rw-r--r--lang/python33/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index c7872f59ff29..61706e10b759 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python33
PORTVERSION= 3.3.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -33,13 +33,14 @@ MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC LIBFFI
+OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS LIBFFI
OPTIONS_SUB= yes
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
TSC_DESC= Enable processor timestamp counter profiling
+LIBFFI_DESC= Use libffi from ports instead of bundled version
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
@@ -69,6 +70,11 @@ ABIFLAGS:= m${ABIFLAGS}
ABIFLAGS:= d${ABIFLAGS}
.endif
+.if ${PORT_OPTIONS:MLIBFFI}
+CONFIGURE_ARGS+= --with-system-ffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
+.endif
+
.if !empty(ABIFLAGS)
PLIST_FILES+= bin/python3.3%%ABI%%
PLIST_FILES+= bin/python3.3%%ABI%%-config