aboutsummaryrefslogtreecommitdiff
path: root/lang/python34/files/patch-Makefile.pre.in
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python34/files/patch-Makefile.pre.in')
-rw-r--r--lang/python34/files/patch-Makefile.pre.in44
1 files changed, 44 insertions, 0 deletions
diff --git a/lang/python34/files/patch-Makefile.pre.in b/lang/python34/files/patch-Makefile.pre.in
new file mode 100644
index 000000000000..66c65e8407c9
--- /dev/null
+++ b/lang/python34/files/patch-Makefile.pre.in
@@ -0,0 +1,44 @@
+# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
+# Changeset: https://svnweb.freebsd.org/ports?view=revision&revision=326729
+# Submitted by: koobs@
+# TODO: Upstream
+
+# Description: Run ranlib before installing the library read-only
+# Changeset: https://svnweb.freebsd.org/ports?view=revision&revision=350207
+# Submitted by: antoine@
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2014-03-17 13:31:30.000000000 +1100
++++ ./Makefile.pre.in 2014-04-06 18:21:28.147616242 +1000
+@@ -70,18 +70,15 @@
+ OPT= @OPT@
+ BASECFLAGS= @BASECFLAGS@
+ BASECPPFLAGS= @BASECPPFLAGS@
+-CONFIGURE_CFLAGS= @CFLAGS@
+-CONFIGURE_CPPFLAGS= @CPPFLAGS@
+-CONFIGURE_LDFLAGS= @LDFLAGS@
+ # Avoid assigning CFLAGS, LDFLAGS, etc. so users can use them on the
+ # command line to append to these values without stomping the pre-set
+ # values.
+-PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CONFIGURE_CFLAGS) $(CFLAGS) $(EXTRA_CFLAGS)
++PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CFLAGS) $(EXTRA_CFLAGS)
+ # Both CPPFLAGS and LDFLAGS need to contain the shell's value for setup.py to
+ # be able to build extension modules using the directories specified in the
+ # environment variables
+-PY_CPPFLAGS= $(BASECPPFLAGS) -I. -IInclude -I$(srcdir)/Include $(CONFIGURE_CPPFLAGS) $(CPPFLAGS)
+-PY_LDFLAGS= $(CONFIGURE_LDFLAGS) $(LDFLAGS)
++PY_CPPFLAGS= $(BASECPPFLAGS) -I. -IInclude -I$(srcdir)/Include $(CPPFLAGS)
++PY_LDFLAGS= $(LDFLAGS)
+ NO_AS_NEEDED= @NO_AS_NEEDED@
+ LDLAST= @LDLAST@
+ SGI_ABI= @SGI_ABI@
+@@ -1314,8 +1311,8 @@
+ if test "$(SHLIB_SUFFIX)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \