aboutsummaryrefslogtreecommitdiff
path: root/lang/quickjs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/quickjs/Makefile')
-rw-r--r--lang/quickjs/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/lang/quickjs/Makefile b/lang/quickjs/Makefile
index 4de59e6fcbb7..57d07ac893ff 100644
--- a/lang/quickjs/Makefile
+++ b/lang/quickjs/Makefile
@@ -11,6 +11,16 @@ COMMENT= Embeddable Javascript interpreter in C
LICENSE= MIT
-USES= gmake tar:xz
+USES= compiler:c11 gmake tar:xz
-.include <bsd.port.mk>
+EXTRA_PATCHES= ${FILESDIR}/extra-${CHOSEN_COMPILER_TYPE}-patch-Makefile
+
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+post-patch:
+ @${REINPLACE_CMD} -e 's/%%GCC_DEFAULT%%/${GCC_DEFAULT}/' \
+ ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>