aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby18/Makefile')
-rw-r--r--lang/ruby18/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 546233d2a967..ec8154bdb83f 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -34,6 +34,10 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
_RUBY_SYSLIBDIR= ${PREFIX}/lib
+.ifdef(WITH_OPENSSL_PORT)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ext_openssl_openssl_missing.h
+.endif
+
OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
ONIGURUMA "Build with oniguruma regular expressions lib" off \
GCPATCH "Build with GC performance statistics collector" off \