aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby21/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby21/files/patch-configure.in')
-rw-r--r--lang/ruby21/files/patch-configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/lang/ruby21/files/patch-configure.in b/lang/ruby21/files/patch-configure.in
index 3b13a6437fe2..0f309e87cb68 100644
--- a/lang/ruby21/files/patch-configure.in
+++ b/lang/ruby21/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2014-02-17 23:26:58.602684892 +0000
-+++ configure.in 2014-02-17 23:30:59.146669242 +0000
-@@ -1072,10 +1072,10 @@
+--- configure.in.orig 2014-02-21 23:32:34.000000000 +0000
++++ configure.in 2014-02-24 14:54:59.432610152 +0000
+@@ -1084,10 +1084,10 @@
],
[ LIBS="-lm $LIBS"])
@@ -15,7 +15,7 @@
dnl Checks for header files.
AC_HEADER_DIRENT
-@@ -1970,7 +1970,7 @@
+@@ -1982,7 +1982,7 @@
if test x"$ac_cv_func_clock_gettime" != xyes; then
# glibc 2.17 moves clock_* functions from librt to the main C library.
# http://sourceware.org/ml/libc-announce/2012/msg00001.html
@@ -24,7 +24,7 @@
if test x"$ac_cv_lib_rt_clock_gettime" = xyes; then
AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
fi
-@@ -2411,7 +2411,7 @@
+@@ -2423,7 +2423,7 @@
fi
if test x"$enable_pthread" = xyes; then
@@ -33,7 +33,7 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
-@@ -2419,6 +2419,7 @@
+@@ -2431,6 +2431,7 @@
if test x"$rb_with_pthread" = xyes; then
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
@@ -41,15 +41,15 @@
AC_DEFINE(HAVE_LIBPTHREAD)
AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
AS_CASE([$pthread_lib],
-@@ -2656,7 +2657,6 @@
+@@ -2668,7 +2669,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
-- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi
-@@ -3109,6 +3109,7 @@
+@@ -3136,6 +3136,7 @@
[freebsd*|dragonfly*], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'