aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile18
-rw-r--r--lang/rust/distinfo8
-rw-r--r--lang/rust/files/patch-configure24
-rw-r--r--lang/rust/files/patch-mk_platform.mk35
-rw-r--r--lang/rust/files/tgammaf.patch4
-rw-r--r--lang/rust/pkg-plist25
6 files changed, 71 insertions, 43 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index f4c17a852b0a..16197c680b73 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: rust
-# Date created: 2012-01-21
-# Whom: Jyun-Yan You <jyyou@cs.nctu.edu.tw>
-#
+# Created by: Jyun-Yan You <jyyou@cs.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= rust
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= lang
-MASTER_SITES= http://dl.rust-lang.org/dist/:src \
- http://dl.rust-lang.org/stage0-snapshots/:boot
+MASTER_SITES= http://static.rust-lang.org/dist/:src \
+ http://static.rust-lang.org/stage0-snapshots/:boot
DISTFILES= ${RUST_SOURCE}:src \
${RUST_BOOT}:boot
EXTRACT_ONLY= ${RUST_SOURCE}
@@ -19,7 +15,7 @@ COMMENT= A language with a focus on memory safety and concurrency
RUST_SOURCE= ${DISTNAME}${EXTRACT_SUFX}
RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
-RUST_BOOT_SIG= 2012-10-09-cd6f24f-freebsd-x86_64-a2b5e9dddfa8f21cc8a068b77a47ba5425bfdcc6
+RUST_BOOT_SIG= 2012-12-19-8554d5e-freebsd-x86_64-2bffa280f338913c735672f6ddb630c6da126fad
RUST_TARGET= x86_64-unknown-freebsd
ONLY_FOR_ARCHS= amd64
@@ -52,7 +48,7 @@ CC= clang
CXX= clang++
CONFIGURE_ARGS+= --enable-clang
.else
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
.if ${PORT_OPTIONS:MCARGO}
@@ -87,7 +83,7 @@ post-patch:
${WRKSRC}/mk/stage0.mk
.if empty(PORT_OPTIONS:MCARGO)
${REINPLACE_CMD} \
- -e '/$$(Q)$$(call INSTALL,$$(HB3),$$(PHB),cargo$$(X))/d' \
+ -e '/$$(Q)$$(call INSTALL,$$(HB2),$$(PHB),cargo$$(X))/d' \
${WRKSRC}/mk/install.mk
.endif
diff --git a/lang/rust/distinfo b/lang/rust/distinfo
index 31a7f2d87b83..ea4d094121f5 100644
--- a/lang/rust/distinfo
+++ b/lang/rust/distinfo
@@ -1,4 +1,4 @@
-SHA256 (rust-0.4.tar.gz) = 150685f07e4d605cadf9fba25b05e9cc1b009364dd744131cf4230d64981d093
-SIZE (rust-0.4.tar.gz) = 24104527
-SHA256 (rust-stage0-2012-10-09-cd6f24f-freebsd-x86_64-a2b5e9dddfa8f21cc8a068b77a47ba5425bfdcc6.tar.bz2) = 6ef8e6af1af853ed391ff90063deeae3593954b271724d78104e6f31ebb8a470
-SIZE (rust-stage0-2012-10-09-cd6f24f-freebsd-x86_64-a2b5e9dddfa8f21cc8a068b77a47ba5425bfdcc6.tar.bz2) = 13084348
+SHA256 (rust-0.5.tar.gz) = d326d22707f0562d669c11efbc33ae812ddbf76ab78f07087fc5beb095a8928a
+SIZE (rust-0.5.tar.gz) = 24304179
+SHA256 (rust-stage0-2012-12-19-8554d5e-freebsd-x86_64-2bffa280f338913c735672f6ddb630c6da126fad.tar.bz2) = 31d960789db8c7b67d2760ddbc7b397e21d2fc7c6e872c3ae0186c2d2f2e8006
+SIZE (rust-stage0-2012-12-19-8554d5e-freebsd-x86_64-2bffa280f338913c735672f6ddb630c6da126fad.tar.bz2) = 13856177
diff --git a/lang/rust/files/patch-configure b/lang/rust/files/patch-configure
index d106116a908d..da7744e5f074 100644
--- a/lang/rust/files/patch-configure
+++ b/lang/rust/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-10-16 22:28:10.833921513 +0800
-+++ configure 2012-10-16 22:30:18.122921502 +0800
-@@ -312,7 +312,6 @@
+--- configure.orig 2012-12-19 07:29:12.000000000 +0800
++++ configure 2012-12-24 20:52:33.524922231 +0800
+@@ -363,7 +363,6 @@
step_msg "looking for build programs"
probe_need CFG_PERL perl
@@ -8,7 +8,23 @@
probe_need CFG_PYTHON python2.7 python2.6 python2 python
python_version=$($CFG_PYTHON -V 2>&1)
-@@ -451,7 +450,7 @@
+@@ -472,15 +471,6 @@
+ fi
+ fi
+
+-# Force freebsd to build with clang; gcc doesn't like us there
+-if [ $CFG_OSTYPE = unknown-freebsd ]
+-then
+- step_msg "on FreeBSD, forcing use of clang"
+- CFG_ENABLE_CLANG=1
+- putvar CFG_ENABLE_CLANG
+-fi
+-
+-
+ if [ -z "$CFG_ENABLE_CLANG" -a -z "$CFG_GCC" ]
+ then
+ err "either clang or gcc is required"
+@@ -516,7 +506,7 @@
| cut -d ' ' -f 2)
case $CFG_CLANG_VERSION in
diff --git a/lang/rust/files/patch-mk_platform.mk b/lang/rust/files/patch-mk_platform.mk
index 7d56a0b99fac..e699a662bcef 100644
--- a/lang/rust/files/patch-mk_platform.mk
+++ b/lang/rust/files/patch-mk_platform.mk
@@ -1,20 +1,27 @@
---- mk/platform.mk.orig 2012-04-05 22:34:59.678608449 +0800
-+++ mk/platform.mk 2012-04-05 22:35:13.749110633 +0800
-@@ -213,7 +213,7 @@
+--- mk/platform.mk.orig 2012-12-25 08:33:07.971922333 +0800
++++ mk/platform.mk 2012-12-25 08:33:16.996994081 +0800
+@@ -222,7 +222,7 @@
ifeq ($(origin CPP),default)
- CPP=cpp
+ CPP=clang -E
endif
-- CFG_GCCISH_CFLAGS += -Wall -Werror -fno-rtti -g
-+ CFG_GCCISH_CFLAGS += -Wall -fno-rtti -g
+- CFG_GCCISH_CFLAGS += -Wall -Werror -g
++ CFG_GCCISH_CFLAGS += -Wall -g
+ CFG_GCCISH_CXXFLAGS += -fno-rtti
CFG_GCCISH_LINK_FLAGS += -g
- CFG_DEPEND_C = $(CFG_GCCISH_CROSS)$(CXX) $(CFG_GCCISH_CFLAGS) -MT "$(1)" \
- -MM $(2)
-@@ -244,7 +244,7 @@
+ # These flags will cause the compiler to produce a .d file
+@@ -268,7 +268,7 @@
ifeq ($(origin CPP),default)
- CPP=cpp
+ CPP=gcc -E
endif
-- CFG_GCCISH_CFLAGS += -Wall -Werror -fno-rtti -g
-+ CFG_GCCISH_CFLAGS += -Wall -fno-rtti -g
+- CFG_GCCISH_CFLAGS += -Wall -Werror -g
++ CFG_GCCISH_CFLAGS += -Wall -g
+ CFG_GCCISH_CXXFLAGS += -fno-rtti
CFG_GCCISH_LINK_FLAGS += -g
- CFG_DEPEND_C = $(CFG_GCCISH_CROSS)$(CXX) $(CFG_GCCISH_CFLAGS) -MT "$(1)" \
- -MM $(2)
+ # These flags will cause the compiler to produce a .d file
+@@ -322,4 +322,4 @@
+ endef
+
+ $(foreach target,$(CFG_TARGET_TRIPLES),\
+- $(eval $(call CFG_MAKE_ASSEMBLER,$(target))))
+\ No newline at end of file
++ $(eval $(call CFG_MAKE_ASSEMBLER,$(target))))
diff --git a/lang/rust/files/tgammaf.patch b/lang/rust/files/tgammaf.patch
index a548e804bcdd..ec35761daf40 100644
--- a/lang/rust/files/tgammaf.patch
+++ b/lang/rust/files/tgammaf.patch
@@ -14,7 +14,7 @@
pub use cmath::c_float::*;
pub use cmath::c_float_targ_consts::*;
-+priv use cmath::c_double;
++priv use cmath::c_double_utils;
+
// These are not defined inside consts:: for consistency with
// the integer types
@@ -24,7 +24,7 @@
}
+pub pure fn tgamma(n: f32) -> f32 {
-+ return c_double::tgamma(n as f64) as f32;
++ return c_double_utils::tgamma(n as f64) as f32;
+}
+
pub pure fn signbit(x: f32) -> int {
diff --git a/lang/rust/pkg-plist b/lang/rust/pkg-plist
index 0e6a68283a7d..e719780535d5 100644
--- a/lang/rust/pkg-plist
+++ b/lang/rust/pkg-plist
@@ -1,18 +1,27 @@
%%CARGO%%bin/cargo
bin/rustc
bin/rustdoc
-lib/libcore-c3ca5d77d81b46c1-0.4.so
-lib/librustc-c84825241471686d-0.4.so
+bin/rusti
+lib/libcargo.so
+lib/libcore-c3ca5d77d81b46c1-0.5.so
+lib/librustc-c84825241471686d-0.5.so
+lib/librustc.so
+lib/librustdoc.so
+lib/librusti-5047c7f210c7cac8-0.5.so
+lib/librusti.so
lib/librustllvm.so
lib/librustrt.so
-lib/libstd-4782a756585a81-0.4.so
-lib/libsyntax-84efebcb12c867a2-0.4.so
-lib/rustc/x86_64-unknown-freebsd/lib/libcore-c3ca5d77d81b46c1-0.4.so
+lib/libstd-4782a756585a81-0.5.so
+lib/libsyntax-84efebcb12c867a2-0.5.so
+lib/rustc/x86_64-unknown-freebsd/lib/libcargo-4951d6ef10eecbb6-0.5.so
+lib/rustc/x86_64-unknown-freebsd/lib/libcore-c3ca5d77d81b46c1-0.5.so
lib/rustc/x86_64-unknown-freebsd/lib/libmorestack.a
-lib/rustc/x86_64-unknown-freebsd/lib/librustc-c84825241471686d-0.4.so
+lib/rustc/x86_64-unknown-freebsd/lib/librustc-c84825241471686d-0.5.so
+lib/rustc/x86_64-unknown-freebsd/lib/librustdoc-1ac3c0763957e4b0-0.5.so
+lib/rustc/x86_64-unknown-freebsd/lib/librusti-5047c7f210c7cac8-0.5.so
lib/rustc/x86_64-unknown-freebsd/lib/librustrt.so
-lib/rustc/x86_64-unknown-freebsd/lib/libstd-4782a756585a81-0.4.so
-lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-84efebcb12c867a2-0.4.so
+lib/rustc/x86_64-unknown-freebsd/lib/libstd-4782a756585a81-0.5.so
+lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-84efebcb12c867a2-0.5.so
@dirrm lib/rustc/x86_64-unknown-freebsd/lib
@dirrm lib/rustc/x86_64-unknown-freebsd
@dirrm lib/rustc