aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 83df9263217a..755388539c7b 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -333,6 +333,14 @@ do-test:
--config ./config.toml \
--jobs ${MAKE_JOBS_NUMBER}
+makesum-all-archs:
+ ${MAKE} makesum ARCH=${ONLY_FOR_ARCHS:[1]}
+.for arch in ${ONLY_FOR_ARCHS:[2..-1]}
+ ${MAKE} makesum ARCH=${arch} DISTINFO_FILE=${DISTINFO_FILE}.${arch}
+ ${GREP} ${RUST_ARCH_${arch}} ${DISTINFO_FILE}.${arch} >> ${DISTINFO_FILE}
+ ${RM} ${DISTINFO_FILE}.${arch}
+.endfor
+
BOOTSTRAPS_SOURCE_PKG_FBSDVER= 10
BOOTSTRAPS_SOURCE_PKG_FBSDVER_aarch64= 11
BOOTSTRAPS_SOURCE_PKG_REV=