aboutsummaryrefslogtreecommitdiff
path: root/lang/seed7
diff options
context:
space:
mode:
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 5e1b1ddc0955..515d1e7ca447 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -24,6 +24,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/src
MAKEFILE= makefile
ALL_TARGET= hi
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+BROKEN= does not compile
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;\
s|`pwd`|${PREFIX}/lib/${PORTNAME}|g;\
@@ -58,4 +64,4 @@ test: install
@echo "Testing the ${PORTNAME} installation"
@(cd ${WRKSRC}/../prg && ${PREFIX}/bin/hi chk_all)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>