aboutsummaryrefslogtreecommitdiff
path: root/lang/squeak-dev/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/squeak-dev/files')
-rw-r--r--lang/squeak-dev/files/patch-platforms::Cross::plugins::DropPlugin::DropPlugin.h7
-rw-r--r--lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::JPEGReadWriter2Plugin.h10
-rw-r--r--lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::jmemdatasrc.c10
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::config::configure10
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::npsqueak::Makefile20
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::npsqueak::npsqueakregister.in13
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::plugins::PseudoTTYPlugin::openpty.h14
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::Makefile.in11
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::ffi-config10
-rw-r--r--lang/squeak-dev/files/patch-platforms::unix::vm-sound-OSS::acinclude.m411
-rw-r--r--lang/squeak-dev/files/patch-platforms__unix__config__inisqueak.in23
-rw-r--r--lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueak.c20
-rw-r--r--lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueakrun.in38
-rw-r--r--lang/squeak-dev/files/pkg-message.in22
14 files changed, 0 insertions, 219 deletions
diff --git a/lang/squeak-dev/files/patch-platforms::Cross::plugins::DropPlugin::DropPlugin.h b/lang/squeak-dev/files/patch-platforms::Cross::plugins::DropPlugin::DropPlugin.h
deleted file mode 100644
index ac04be2c3c10..000000000000
--- a/lang/squeak-dev/files/patch-platforms::Cross::plugins::DropPlugin::DropPlugin.h
+++ /dev/null
@@ -1,7 +0,0 @@
---- platforms/Cross/plugins/DropPlugin/DropPlugin.h.orig Thu May 13 16:07:09 2004
-+++ platforms/Cross/plugins/DropPlugin/DropPlugin.h Thu May 13 16:05:52 2004
-@@ -10,3 +10,4 @@
- int sqSecFileAccessCallback(void *);
- void sqSetNumberOfDropFiles(int numberOfFiles);
- void sqSetFileInformation(int dropIndex, void *dropFile);
-+
diff --git a/lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::JPEGReadWriter2Plugin.h b/lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::JPEGReadWriter2Plugin.h
deleted file mode 100644
index d1f69cfbbd48..000000000000
--- a/lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::JPEGReadWriter2Plugin.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- platforms/Cross/plugins/JPEGReadWriter2Plugin/JPEGReadWriter2Plugin.h.orig Thu May 13 16:09:52 2004
-+++ platforms/Cross/plugins/JPEGReadWriter2Plugin/JPEGReadWriter2Plugin.h Thu May 13 16:10:08 2004
-@@ -14,4 +14,5 @@
- void error_exit (j_common_ptr cinfo);
- GLOBAL(void) jpeg_mem_src (j_decompress_ptr cinfo, char * pSourceData, unsigned sourceDataSize);
- GLOBAL(int) jpeg_mem_src_newLocationOfData (j_decompress_ptr cinfo, char * pSourceData, unsigned sourceDataSize);
--GLOBAL(void) jpeg_mem_dest (j_compress_ptr cinfo, char * pDestination, unsigned *pDestinationSize);
-\ No newline at end of file
-+GLOBAL(void) jpeg_mem_dest (j_compress_ptr cinfo, char * pDestination, unsigned *pDestinationSize);
-+
diff --git a/lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::jmemdatasrc.c b/lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::jmemdatasrc.c
deleted file mode 100644
index a20e88f8d371..000000000000
--- a/lang/squeak-dev/files/patch-platforms::Cross::plugins::JPEGReadWriter2Plugin::jmemdatasrc.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- platforms/Cross/plugins/JPEGReadWriter2Plugin/jmemdatasrc.c.orig Thu May 13 16:25:49 2004
-+++ platforms/Cross/plugins/JPEGReadWriter2Plugin/jmemdatasrc.c Thu May 13 16:25:58 2004
-@@ -198,4 +198,5 @@
- src->actualPos = pSourceData + offset;
-
- return((src->actualPos + src->bytesLeft) == (pSourceData + sourceDataSize));
--}
-\ No newline at end of file
-+}
-+
diff --git a/lang/squeak-dev/files/patch-platforms::unix::config::configure b/lang/squeak-dev/files/patch-platforms::unix::config::configure
deleted file mode 100644
index 38f45aa494ec..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::config::configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- platforms/unix/config/configure.orig Mon May 10 10:54:48 2004
-+++ platforms/unix/config/configure Mon May 10 10:54:15 2004
-@@ -23526,6 +23526,7 @@
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
- #include <sys/soundcard.h>
-+#define OPEN_SOUND_SYSTEM
- int
- main ()
- {
diff --git a/lang/squeak-dev/files/patch-platforms::unix::npsqueak::Makefile b/lang/squeak-dev/files/patch-platforms::unix::npsqueak::Makefile
deleted file mode 100644
index f8692044db87..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::npsqueak::Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- platforms/unix/npsqueak/Makefile.orig Sat Aug 23 06:59:39 2003
-+++ platforms/unix/npsqueak/Makefile Fri Nov 24 18:55:48 2006
-@@ -3,7 +3,7 @@
-
- ############ Customize flags here #######################
-
--INC = -I./include -I/usr/X11R6/include
-+INC = -I./include -I%%X11BASE%%/include
- CC = gcc
- CFLAGS = $(INC) -O2 -fPIC -Wall
- LD = gcc
-@@ -20,7 +20,7 @@
- ############ compile and link ###########################
-
- npsqueak.so : npsqueak.o npunix.o
-- $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so
-+ $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so -L%%X11BASE%%/lib -lXt -lX11
-
- npsqueak.o: npsqueak.c ../config.h
- $(CC) -c $(CFLAGS) -DVM_LIBDIR=\"$(VM_LIBDIR)\" $<
diff --git a/lang/squeak-dev/files/patch-platforms::unix::npsqueak::npsqueakregister.in b/lang/squeak-dev/files/patch-platforms::unix::npsqueak::npsqueakregister.in
deleted file mode 100644
index a4ba55ad46d4..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::npsqueak::npsqueakregister.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- platforms/unix/npsqueak/npsqueakregister.in.orig Sun Mar 20 05:38:26 2005
-+++ platforms/unix/npsqueak/npsqueakregister.in Fri Oct 6 21:02:25 2006
-@@ -8,8 +8,8 @@
- # Parameters: -u unregister
-
- NPSQUEAK_SO=@NPSQUEAK_SO@
--BROWSERS="netscape mozilla mozilla-firefox opera MozillaFirefox/lib"
--BROWSER_DIRS="/usr/local/lib /usr/lib /opt"
-+BROWSERS="netscape mozilla firefox opera seamonkey"
-+BROWSER_DIRS="%%X11BASE%%/lib %%X11BASE%%/share %%LOCALBASE%%/lib %%LOCALBASE%%/share /usr/lib"
- SYSTEM_BROWSER_DIR="/usr/lib/browser-plugins"
-
- ACTION=register
diff --git a/lang/squeak-dev/files/patch-platforms::unix::plugins::PseudoTTYPlugin::openpty.h b/lang/squeak-dev/files/patch-platforms::unix::plugins::PseudoTTYPlugin::openpty.h
deleted file mode 100644
index 36dd49bcd97b..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::plugins::PseudoTTYPlugin::openpty.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- platforms/unix/plugins/PseudoTTYPlugin/openpty.h.orig Tue Jan 14 16:02:55 2003
-+++ platforms/unix/plugins/PseudoTTYPlugin/openpty.h Tue Jan 14 16:03:09 2003
-@@ -45,7 +45,10 @@
- # elif defined(HAVE_LIBUTIL_H)
- # include <libutil.h> /* openpty() on FreeBSD */
- # else
--# error: cannot find headers for openpty()
-+# include <sys/types.h>
-+# include <sys/ioctl.h>
-+# include <termios.h>
-+# include <libutil.h>
- # endif
-
- #else /* !HAVE_OPENPTY */
diff --git a/lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::Makefile.in b/lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::Makefile.in
deleted file mode 100644
index 3c0fd9e7894e..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- platforms/unix/plugins/SqueakFFIPrims/Makefile.in.orig Sun Mar 20 05:38:18 2005
-+++ platforms/unix/plugins/SqueakFFIPrims/Makefile.in Sun Feb 26 00:08:03 2006
-@@ -14,7 +14,7 @@
- XINCLUDES = [includes]
-
- $(TARGET) : $(OBJS) Makefile
-- $(LINK) $(TARGET) $(OBJS)
-+ $(LINK) $(TARGET) $(OBJS) -lffi
- $(RANLIB) $(TARGET)
-
- [make_targets]
diff --git a/lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::ffi-config b/lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::ffi-config
deleted file mode 100644
index 80ded9fb17c9..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::plugins::SqueakFFIPrims::ffi-config
+++ /dev/null
@@ -1,10 +0,0 @@
---- platforms/unix/plugins/SqueakFFIPrims/ffi-config.org Wed Apr 26 20:27:53 2006
-+++ platforms/unix/plugins/SqueakFFIPrims/ffi-config Wed Apr 26 20:29:00 2006
-@@ -39,6 +39,7 @@
-
- case ${abi} in
- linux) abi=sysv;;
-+ freebsd*) abi=sysv;;
- darwin*) abi=darwin;;
- *) abi=libffi; lib="-lffi";;
- esac
diff --git a/lang/squeak-dev/files/patch-platforms::unix::vm-sound-OSS::acinclude.m4 b/lang/squeak-dev/files/patch-platforms::unix::vm-sound-OSS::acinclude.m4
deleted file mode 100644
index 3fb9e7e023a1..000000000000
--- a/lang/squeak-dev/files/patch-platforms::unix::vm-sound-OSS::acinclude.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- platforms/unix/vm-sound-OSS/acinclude.m4.orig Mon May 10 10:18:03 2004
-+++ platforms/unix/vm-sound-OSS/acinclude.m4 Mon May 10 10:18:22 2004
-@@ -1,7 +1,7 @@
- # -*- sh -*-
-
- AC_MSG_CHECKING([for Open Sound System])
--AC_TRY_COMPILE([#include <sys/soundcard.h>],[OPEN_SOUND_SYSTEM;],[
-+AC_TRY_COMPILE([#include <sys/soundcard.h>],[EV_SEQ_LOCAL;],[
- AC_MSG_RESULT(yes)
- ],[
- AC_MSG_RESULT(no)
diff --git a/lang/squeak-dev/files/patch-platforms__unix__config__inisqueak.in b/lang/squeak-dev/files/patch-platforms__unix__config__inisqueak.in
deleted file mode 100644
index f756bee6026e..000000000000
--- a/lang/squeak-dev/files/patch-platforms__unix__config__inisqueak.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- platforms/unix/config/inisqueak.in.org Mon Feb 6 15:10:05 2006
-+++ platforms/unix/config/inisqueak.in Mon Feb 6 15:10:58 2006
-@@ -99,7 +99,7 @@
- exit 1
- }
-
--if ${test} \( -f squeak.image \) -a \( -f squeak.changes \) -a \( -e ${SOURCES} \)
-+if ${test} \( -f squeak.image \) -a \( -e ${SOURCES} \)
- then
- if ${startup}; then
- if test ! -x ${SQUEAK}; then
-@@ -200,7 +200,10 @@
-
- install "ln -s" "${imgdir}/${SOURCES}" " " "${SOURCES}"
- install "gunzip -dc" "${imgdir}/${IMAGE}" ">" "squeak.image"
--install "gunzip -dc" "${imgdir}/${CHANGES}" ">" "squeak.changes"
-+# For SqueakPlugin.image which don't have changes file.
-+if test -e "${imgdir}/${CHANGES}"; then
-+ install "gunzip -dc" "${imgdir}/${CHANGES}" ">" "squeak.changes"
-+fi
-
- if ${startup}; then
- if test ! -x ${SQUEAK}; then
diff --git a/lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueak.c b/lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueak.c
deleted file mode 100644
index 20eddcbb168b..000000000000
--- a/lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueak.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- platforms/unix/npsqueak/npsqueak.c.orig Sun Mar 20 05:38:26 2005
-+++ platforms/unix/npsqueak/npsqueak.c Sat Oct 7 19:56:10 2006
-@@ -177,13 +177,16 @@
- findFileInPaths(char* result, char *filename, int dirn, char *dirv[PATH_MAX]){
- int i;
- char path[PATH_MAX];
-+ char gzipedpath[PATH_MAX];
-
- for(i= 0; i < dirn; i++){
- DPRINT("NP: search \"%s\" in \"%s\" \n",filename,dirv[i]);
-
- strcpy(path, dirv[i]);
- strcat(path, filename);
-- if (access(path, R_OK) == 0){
-+ strcpy(gzipedpath, path);
-+ strcat(gzipedpath, ".gz");
-+ if (access(path, R_OK) == 0 || access(gzipedpath, R_OK) == 0){
- DPRINT("NP: \"%s\" in \"%s\" found\n",filename,dirv[i]);
- return strcpy(result, path);
- }
diff --git a/lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueakrun.in b/lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueakrun.in
deleted file mode 100644
index 0a6058b52ab4..000000000000
--- a/lang/squeak-dev/files/patch-platforms__unix__npsqueak__npsqueakrun.in
+++ /dev/null
@@ -1,38 +0,0 @@
---- platforms/unix/npsqueak/npsqueakrun.in.orig Sun Mar 20 05:38:26 2005
-+++ platforms/unix/npsqueak/npsqueakrun.in Sun Jan 7 16:30:12 2007
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#! %%LOCALBASE%%/bin/bash
-
- # File: npsqueakrun
- # Author: Bert Freudenberg
-@@ -60,12 +60,24 @@
- ensurefile()
- {
- if [ ! -e "${1}" ] ; then
-- if cp "${2}" "${1}" ; then
-- pdebug "Created ${1}"
-+ if [ -e "${2}" ] ;then
-+ if cp "${2}" "${1}" ; then
-+ pdebug "Created ${1}"
-+ else
-+ perror "Could not create ${1}"
-+ if [ ! -r "${2}" ] ; then
-+ perror "because ${2} is missing"
-+ fi
-+ fi
- else
-- perror "Could not create ${1}"
-- if [ ! -r "${2}" ] ; then
-- perror "because ${2} is missing"
-+ if [ -e "${2}.gz" ] ; then
-+ gunzip -c "${2}.gz" > "${1}"
-+ pdebug "Created ${1} from ${2}.gz"
-+ else
-+ perror "Could not create ${1}"
-+ if [ ! -r "${2}" ] ; then
-+ perror "because ${2} is missing"
-+ fi
- fi
- fi
- fi
diff --git a/lang/squeak-dev/files/pkg-message.in b/lang/squeak-dev/files/pkg-message.in
deleted file mode 100644
index b19bc6aa0dd2..000000000000
--- a/lang/squeak-dev/files/pkg-message.in
+++ /dev/null
@@ -1,22 +0,0 @@
- ------------------------- Please note: -------------------------
-
- In order to be able to make use of squeak you need to have an
- image and a changes file in your working directory as well
- as access to a source file. This is easy by using inisqueak.
- Please see the inisqueak(1) manpage for details.
-
- Make sure you have the following values in your environment
- variables:
- PATH: %%PREFIX%%/bin
- LD_LIBRARY_PATH: %%PREFIX%%/lib
- %%PREFIX%%/share/squeak/%%VMVERSION%%
-
- If you want to use web browser plugin,
- run %%PREFIX%%/share/squeak/npsqueakregister.
-
- If you want to use (Japanese) XIM at full screen,
- you get changeset at
- http://squeak.610t.org/patches/CompositionFocus.1.cs
- and file in it.
- ------------------ Thanks for your attention! ------------------
-