aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl83/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tcl83/Makefile')
-rw-r--r--lang/tcl83/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index 0bd62be7c3f3..b9eb7a979850 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.3.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang tcl83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
@@ -31,6 +31,10 @@ NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
USE_REINPLACE= YES
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TCL83_MAN)
+
MAN1= tclsh.1
MAN3= Access.3 AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 \
@@ -421,11 +425,15 @@ MLINKS= Access.3 Tcl_Access.3 \
safe.n Safe\Base.n \
tcltest.n Tcltest.n
-.include <bsd.port.pre.mk>
+.endif
post-configure:
${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}${PORTSDIR}=$${WRKDIRPREFIX}${PORTSDIR}=' \
${WRKSRC}/tclConfig.sh
+.if !defined(WITH_TCL83_MAN)
+ ${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
+ ${WRKSRC}/Makefile
+.endif
post-install:
.if exists(${PKGINSTALL})