aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl84/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tcl84/Makefile')
-rw-r--r--lang/tcl84/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index 7b80c8c78f3c..ced4e7ea3014 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tcl
-PORTVERSION= 8.4.1
+PORTVERSION= 8.4.2
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -28,6 +28,7 @@ PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.4
NOPRECIOUSMAKEVARS= Too many _MLINKS for README.html
+USE_REINPLACE= YES
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=84
@@ -588,10 +589,15 @@ PKGNAMESUFFIX?= -threads
USE_REINPLACE= YES
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
.endif
+post-configure:
+ ${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}=$${WRKDIRPREFIX}=' \
+ ${WRKSRC}/tclConfig.sh
+
.include <bsd.port.pre.mk>
post-install: