aboutsummaryrefslogtreecommitdiff
path: root/lang/tinycobol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tinycobol/Makefile')
-rw-r--r--lang/tinycobol/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index 9db885f3e99a..35214fe0551b 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tinycobol
-PORTVERSION= 0.62
+PORTVERSION= 0.63
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tiny-cobol
@@ -23,9 +23,9 @@ HAS_CONFIGURE= yes
USE_BISON= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --with-libdb=3 --with-readline
+CONFIGURE_ARGS= --with-libdb=3
CPPFLAGS= -I${LOCALBASE}/include
-CFLAGS= ${CPPFGLAGS}
+CFLAGS= ${CPPFLAGS}
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -37,4 +37,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/info/*.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# doesn't work with readline on FreeBSD 4.x
+.if ${OSVERSION} >= 500000
+CONFIGURE_ARGS+= --with-readline
+.endif
+
+.include <bsd.port.post.mk>