aboutsummaryrefslogtreecommitdiff
path: root/lang/tolua++/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tolua++/Makefile')
-rw-r--r--lang/tolua++/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/tolua++/Makefile b/lang/tolua++/Makefile
index e6d1d950c890..5df222084a30 100644
--- a/lang/tolua++/Makefile
+++ b/lang/tolua++/Makefile
@@ -9,7 +9,7 @@ PORTNAME= tolua++
PORTVERSION= 1.0.4
CATEGORIES= lang devel
MASTER_SITES= http://www.codenix.com/~tolua/
-DISTNAME= tolua++-current
+DISTFILES= tolua++-current${EXTRACT_SUFX}
MAINTAINER= aaron@FreeBSD.org
COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
@@ -22,6 +22,12 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
NO_BUILD= yes
+post-patch:
+.for f in LOCALBASE LUA_VER LUA_INCDIR LUA_LIBDIR
+ @${REINPLACE_CMD} -i "" -e 's|%%${f}%%|${${f}}|g' \
+ ${WRKSRC}/config_posix.py
+.endfor
+
do-build:
@cd ${WRKSRC} && scons