aboutsummaryrefslogtreecommitdiff
path: root/lang/tolua50
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tolua50')
-rw-r--r--lang/tolua50/Makefile29
-rw-r--r--lang/tolua50/distinfo3
-rw-r--r--lang/tolua50/files/patch-Makefile22
-rw-r--r--lang/tolua50/files/patch-config30
-rw-r--r--lang/tolua50/files/patch-src::tests::Makefile27
-rw-r--r--lang/tolua50/pkg-descr11
-rw-r--r--lang/tolua50/pkg-plist3
7 files changed, 0 insertions, 125 deletions
diff --git a/lang/tolua50/Makefile b/lang/tolua50/Makefile
deleted file mode 100644
index 4c589077c09d..000000000000
--- a/lang/tolua50/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-#
-# New ports collection makefile for: tolua
-# Date created: 21 November 2004
-# Whom: Edwin Groothuis <edwin@mavetju.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= tolua
-PORTVERSION= 5.0.1
-CATEGORIES= lang
-MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/ \
- http://www.tecgraf.puc-rio.br/~celes/tolua/
-
-MAINTAINER= edwin@mavetju.org
-COMMENT= toLua: accessing C/C++ code from Lua
-
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-5.0
-USE_GMAKE= yes
-CONFLICTS= tolua4-.*
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/tolua ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/include/tolua.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/lib/libtolua.a ${PREFIX}/lib
-
-.include <bsd.port.mk>
diff --git a/lang/tolua50/distinfo b/lang/tolua50/distinfo
deleted file mode 100644
index fc31789603d5..000000000000
--- a/lang/tolua50/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (tolua-5.0.1.tar.gz) = da18137d4583880ae474f1e632fcbdc2
-SHA256 (tolua-5.0.1.tar.gz) = a5cc355ecd84c2f8f22588eec41dd047ebe9bad89706c046bcbff4a2e1f7cecb
-SIZE (tolua-5.0.1.tar.gz) = 88676
diff --git a/lang/tolua50/files/patch-Makefile b/lang/tolua50/files/patch-Makefile
deleted file mode 100644
index ea3d00107550..000000000000
--- a/lang/tolua50/files/patch-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig Thu Jul 31 23:27:52 2003
-+++ Makefile Sun Nov 21 18:50:08 2004
-@@ -1,13 +1,13 @@
- # makefile for tolua hierarchy
-
- tolua:
-- cd src/lib; make all
-- cd src/bin; make all
-+ cd src/lib; ${MAKE} all
-+ cd src/bin; ${MAKE} all
-
- tests:
-- cd src/tests; make all
-+ cd src/tests; ${MAKE} all
-
- all clean klean:
-- cd src/lib; make $@
-- cd src/bin; make $@
-- cd src/tests; make $@
-+ cd src/lib; ${MAKE} $@
-+ cd src/bin; ${MAKE} $@
-+ cd src/tests; ${MAKE} $@
diff --git a/lang/tolua50/files/patch-config b/lang/tolua50/files/patch-config
deleted file mode 100644
index 1bd699de6573..000000000000
--- a/lang/tolua50/files/patch-config
+++ /dev/null
@@ -1,30 +0,0 @@
---- config.orig Tue Jun 8 06:09:19 2004
-+++ config Sun Nov 21 19:24:24 2004
-@@ -3,8 +3,9 @@
- # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================
-
- # you need an ANSI C compiler. gcc is a popular one.
--CC= gcc
--CCPP = g++
-+#CC= ${CC}
-+CC = cc
-+CCPP = c++
- WARN= -ansi -Wall
-
- # on SGI's, cc is ANSI.
-@@ -22,6 +23,7 @@
-
- # set lua path
- LUA=/usr/local/lua-5.0
-+LUA=${LOCALBASE}
- LUAINC=$(LUA)/include
- LUALIB=$(LUA)/lib
-
-@@ -30,5 +32,5 @@
- INC= -I$(TOLUA)/include -I$(LUAINC)
- LIB= -L$(TOLUA)/lib -L$(LUALIB)
-
--CFLAGS= -O2 $(WARN) $(INC)
--CPPFLAGS= -O2 $(WARN) $(INC)
-+CFLAGS+= -O2 $(WARN) $(INC)
-+CPPFLAGS+= -O2 $(WARN) $(INC) -lstdc++
diff --git a/lang/tolua50/files/patch-src::tests::Makefile b/lang/tolua50/files/patch-src::tests::Makefile
deleted file mode 100644
index a2aa53e7018d..000000000000
--- a/lang/tolua50/files/patch-src::tests::Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/tests/Makefile.orig Wed Feb 11 23:01:58 2004
-+++ src/tests/Makefile Sun Nov 21 19:17:49 2004
-@@ -4,7 +4,7 @@
-
- include $(TOLUA)/config
-
--LIBS = -ltolua -llua -llualib
-+LIBS = -ltolua -llua -llualib -lm
-
- all: tmodule tnamespace tclass tconstant tvariable tfunction tarray tdirective
- ./tmodule; ./tnamespace; ./tclass; ./tconstant; ./tvariable; ./tfunction; ./tarray; ./tdirective;
-@@ -25,7 +25,7 @@
- $(TOLUA)/bin/tolua -o $@ $<
-
- tnamespace: tnamespace.o tnamespacebind.o
-- $(CC) $(CPPFLAGS) -o $@ tnamespace.o tnamespacebind.o $(TLIB) $(LIB) $(LIBS)
-+ $(CC) $(CPPFLAGS) -Iedwin -o $@ tnamespace.o tnamespacebind.o $(TLIB) $(LIB) $(LIBS)
- tnamespacebind.cpp: tnamespace.pkg
- $(TOLUA)/bin/tolua -o $@ $<
-
-@@ -61,6 +61,3 @@
-
- klean:
- rm -f tmodule tnamespace tclass tconstant tvariable tfunction tarray tdirective
--
--
--
diff --git a/lang/tolua50/pkg-descr b/lang/tolua50/pkg-descr
deleted file mode 100644
index 0dff71b6290c..000000000000
--- a/lang/tolua50/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-toLua is a tool that greatly simplifies the integration of C/C++
-code with Lua. Based on a "cleaned" header file, toLua automatically
-generates the binding code to access C/C++ features from Lua. Using
-Lua-5.0 API and tag method facilities, the current version automatically
-maps C/C++ constants, external variables, functions, namespace,
-classes, and methods to Lua. It also provides facilities to create
-Lua modules.
-
-WWW: http://www.tecgraf.puc-rio.br/~celes/tolua/
-
-Author: Waldemar Celes <celes@tecgraf.puc-rio.br>
diff --git a/lang/tolua50/pkg-plist b/lang/tolua50/pkg-plist
deleted file mode 100644
index 488452014d8f..000000000000
--- a/lang/tolua50/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/tolua
-lib/libtolua.a
-include/tolua.h